modify profile in VM not running

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

metzw
Posts: 3
Joined: Thu Aug 29, 2019 9:23 pm

modify profile in VM not running

Post by metzw » Thu Aug 29, 2019 9:53 pm

Hi,

I have installed the VM for OpenEMM 2019 version 19.04.000.432.

If I now click on Actions -> New Action and select and confirm "modify profile" as action, all fields disappear in the lower part of the input mask.
To rule out errors, I imported the VM into Virtual Box. There is an earlier version with the same error.
Then I signed up for a test account with Agnitas. There is version 19.07.124.023 installed. There this function works.

What can I do?

maschoff
Site Admin
Posts: 2206
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: modify profile in VM not running

Post by maschoff » Fri Aug 30, 2019 8:23 am

Thank you for your bug report! We could reproduce the problem and we will provide a bug fix soon. Bug ID is O-366.
OpenEMM Maintainer

maschoff
Site Admin
Posts: 2206
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: modify profile in VM not running

Post by maschoff » Fri Aug 30, 2019 9:22 am

The bug should be fixed now. Please update openemm-frontend to 19.04.000.465.
OpenEMM Maintainer

metzw
Posts: 3
Joined: Thu Aug 29, 2019 9:23 pm

Re: modify profile in VM not running

Post by metzw » Fri Aug 30, 2019 3:58 pm

Many Thanks.

How can I update the frontend?
How can I find the Update-Files?

maschoff
Site Admin
Posts: 2206
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: modify profile in VM not running

Post by maschoff » Fri Aug 30, 2019 6:31 pm

It is just a few clicks. Use menu 4 of the OpenEMMInstaller. See chapter 6 in the OpenEMM Wiki at https://wiki.openemm.org for details.
OpenEMM Maintainer

metzw
Posts: 3
Joined: Thu Aug 29, 2019 9:23 pm

Re: modify profile in VM not running

Post by metzw » Sun Sep 01, 2019 8:44 pm

I got it :D and figured out why it did not work before:
If you run the update via the installer menu, only the "Utility Package for Deployment & Runtime: 19.07.011" will be displayed.
When executing the direct update command: "/home/openemm/bin/OpenEMMInstaller.sh -update", the updates for "backend" and "frontend" are executed.
In the VM "openemm" is not a sudo user.

mfreundl
Posts: 8
Joined: Wed Aug 28, 2019 10:01 am

Re: modify profile in VM not running

Post by mfreundl » Mon Sep 02, 2019 11:21 am

Hi metzw,
regarding the updating with the installer menu.
After selecting yes on download and install latest (...) packages the menu should ask you if you want to update the runtime, after that it asks for the frontend and then for the backend part. You can select yes or no on each one depending on the version you already have installed.

Post Reply