Upgrading to 2013

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

jim_frey
Posts: 129
Joined: Wed Nov 29, 2006 11:32 pm
Location: Middle Caicos, Turks and Caicos Islands
Contact:

Upgrading to 2013

Post by jim_frey » Mon Jan 28, 2013 7:31 pm

I tried to upgrade to the 2013 version via the link within the application, but now I can't get OpenEMM to boot back up. I think it may be a Java problem, haven't looked into it much yet - don't know if anyone has suggestions?

Here's what the web page said when it was trying to update

Update process starting up
Trying to determinate current running version
Found "2011" as current active version
Looking for new version on remote server (this may take some time)
Found version 2013 on server
Current version is 2011, new version 2013, starting update now
Trying to fetch the new version from one of these URLs:
http://internode.dl.sourceforge.net/pro ... bin.tar.gz
http://ufpr.dl.sourceforge.net/project/ ... bin.tar.gz
http://switch.dl.sourceforge.net/projec ... bin.tar.gz
http://iweb.dl.sourceforge.net/project/ ... bin.tar.gz
http://ignum.dl.sourceforge.net/project ... bin.tar.gz
http://master.dl.sourceforge.net/projec ... bin.tar.gz
http://freefr.dl.sourceforge.net/projec ... bin.tar.gz
http://dfn.dl.sourceforge.net/project/o ... bin.tar.gz
http://jaist.dl.sourceforge.net/project ... bin.tar.gz
http://netcologne.dl.sourceforge.net/pr ... bin.tar.gz
http://superb-dca3.dl.sourceforge.net/p ... bin.tar.gz
http://heanet.dl.sourceforge.net/projec ... bin.tar.gz
http://garr.dl.sourceforge.net/project/ ... bin.tar.gz
http://surfnet.dl.sourceforge.net/proje ... bin.tar.gz
http://aarnet.dl.sourceforge.net/projec ... bin.tar.gz
Be patient, this may take several minutes ...
Trying to download file http://internode.dl.sourceforge.net/pro ... bin.tar.gz
Downloading 76.934 kByte
Download of http://internode.dl.sourceforge.net/pro ... bin.tar.gz successful
Trying to store the new version to /tmp/OpenEMM-2013-bin.tar.gz
Stopping running instance
Shutting down Tomcat ......
Waiting for shutdown of Tomcat:..........Terminating Tomcat the hard way with kill -9 3356
.
Stop scripts/slrtscn.py program .. done.
Stop all sendmail processes: Shutting down sm-client: [FAILED]
Shutting down sendmail: [ OK ]
-15:4104 -15:4107 done.
Stop scripts/pickdist program .. done.
Stop scripts/update.py program .. done.
Stop bin/bav program with signal 15 .. done.
Stop scripts/bavd program .. done.
Stop scripts/bav-trigger program with signal 15 .. done.
Stop scripts/bav-update program with signal 15 .. done.
Renaming current version to keep as archive
Unpacking new version
New version unpacked
Searching for database updates from 2011 to 2013
Database updated from 2011 to 2013
Syncing property files
Starting post process script
Starting new instance
Start /home/openemm/bin/scripts/bav-update.py .. done.
Start /home/openemm/bin/scripts/bav-trigger.py .. done.
Start /home/openemm/bin/scripts/bavd.py .. done.
Start /home/openemm/bin/bav -L INFO .. done.
Start python /home/openemm/bin/scripts/recovery.py .. done.
Start /home/openemm/bin/scripts/update.py account bounce .. done.
Start /home/openemm/bin/scripts/pickdist.py .. done.
Stopping obsolete sendmail processes: done.
Starting sendmails: listener Starting sendmail: [ OK ]
Starting sm-client: [ OK ]
mail queues ADMIN QUEUE MIDQUEUE SLOWQUEUE done.
Start /home/openemm/bin/scripts/slrtscn.py .. done.
Starting up Tomcat ......
Check Java installation :FAILED
Failed to start new instance
Please note:
Below you will find IMPORTANT INFORMATION for users who used the ONLINE UPDATE
feature of OpenEMM to upgrade to this version of OpenEMM. You can reread this
text in file UPDATE.txt at any time. You will find the latest version of this
file at
https://sourceforge.net/projects/openem ... MM%202013/

An update from OpenEMM 5.x or 6.x to 2011 or a later version is not possible,
because starting with version 2011 OpenEMM uses the web container Tomcat, while
OpenEMM 5.x and 6.x work with Resin. Therefore, to get from 5.x or 6.x to 2011
or a later version you have to update OpenEMM manually!
Please read file README.txt for more details.

OPENEMM CMS DATABASE (if you upgrade from OpenEMM before version 6.0)
====================
If your MySQL user root uses a password, the online update of OpenEMM could not
set up the new CMS database. In this case the online update ended with error
message "Failed to postprocess" and the update of OpenEMM is incomplete.

But this is not a problem, because you can set up the CMS database manually
from the command line with

$> mysqladmin -u root -p create openemm_cms
$> mysql -u root -p openemm_cms < /home/openemm/USR_SHARE/openemm_cms-2013.sql


CONFIGURATION FILES
===================
To make sure your configurations files are set up correctly, go to directory
/home/openemm/webapps/openemm/WEB-INF/classes and compare the parameters in
files emm.properties and cms.properties (which were auto-generated by the online
update) with the original files emm.properties-orig and cms.properties-orig in
the same directory to make sure all your individual settings have been copied
successfully.

If you have created a file bav.conf-local in /home/openemm/conf/bav for the
management of delayed bounces, you have to re-create it after the update.
Otherwise it would be missing and the management of delayed bounces would not
work correctly!

If you want to use the webservices interface 2.0 of OpenEMM consult chapter 7.4
of the Install and Administration Guide for configuration details.


(RE)STARTING OPENEMM
====================
When you are finished and OpenEMM has not restarted automatically you have to
restart it manually with
$> su - openemm
$> openemm.sh restart
$> exit


OPENEMM CMS DEMO DATABASE
=========================
To make it easier for you to check out the new Content Manager of OpenEMM file
openemm_demo-cms-2013.sql contains a CMS demo database. You will find this file
in the same directory as file openemm_cms.sql with the empty default CMS
database.

If you want to use the CMS demo database instead of the default CMS database
simply replace the name of file openemm_cms-2013.sql in line 22 above with file
name openemm_demo-cms-2013.sql.

If you already created mailings based on CM templates you should delete these
mailings first because the CMS demo database will overwrite your existing CMS
database and the references from CM template-based mailings would link to
content modules which no longer exist. In this case drop the old CMS database
first with

$> mysqladmin -u root -p drop openemm_cms


DOWNGRADING OPENEMM
===================
If you want to downgrade OpenEMM to a version before 6.2 you have to synchro-
nize 'table customer_1_tbl_seq' with 'customer_1_tbl' before launching the old
version of OpenEMM, because 'customer_1_tbl_seq' is no longer used beginning
with OpenEMM 6.2. Start MySQL, enter the command to 'update customer_1_tbl_seq'
and leave MySQL:
$> mysql -u root -p openemm
mysql> INSERT INTO `customer_1_tbl_seq` (`customer_id`) SELECT max(`customer_id`) FROM `customer_1_tbl`;
mysql> quit
I'm reading over the documentation, just wanted to post this here before I closed the web page.
OpenEMM Moderator

maschoff
Site Admin
Posts: 2209
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Upgrading to 2013

Post by maschoff » Mon Jan 28, 2013 10:06 pm

This points to the problem:

Code: Select all

Check Java installation :FAILED
Maybe you have not installed version 6 of Java or you did not install it at /opt/openemm/java?
OpenEMM Maintainer

jim_frey
Posts: 129
Joined: Wed Nov 29, 2006 11:32 pm
Location: Middle Caicos, Turks and Caicos Islands
Contact:

Re: Upgrading to 2013

Post by jim_frey » Mon Jan 28, 2013 11:02 pm

I have it installed at -
/opt/openemm.org/software/java

Should I link it to the location you posted?
OpenEMM Moderator

maschoff
Site Admin
Posts: 2209
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Upgrading to 2013

Post by maschoff » Tue Jan 29, 2013 7:35 am

Yes.
OpenEMM Maintainer

jim_frey
Posts: 129
Joined: Wed Nov 29, 2006 11:32 pm
Location: Middle Caicos, Turks and Caicos Islands
Contact:

Re: Upgrading to 2013

Post by jim_frey » Wed Jan 30, 2013 8:49 pm

Thanks - I just set up a link -
ln -s /opt/openemm.org/software /opt/openemm

Then it started right up without the Java fail.
OpenEMM Moderator

maschoff
Site Admin
Posts: 2209
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Upgrading to 2013

Post by maschoff » Wed Jan 30, 2013 9:18 pm

Yeah, try that with Windows ... ;-)
OpenEMM Maintainer

jim_frey
Posts: 129
Joined: Wed Nov 29, 2006 11:32 pm
Location: Middle Caicos, Turks and Caicos Islands
Contact:

Re: Upgrading to 2013

Post by jim_frey » Wed Jan 30, 2013 9:35 pm

maschoff wrote:Yeah, try that with Windows ... ;-)
Image
OpenEMM Moderator

Post Reply