Problems with some features after clean installation.

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

bonscot
Posts: 11
Joined: Tue Apr 16, 2024 9:44 pm

Re: Problems with some features after clean installation.

Post by bonscot »

Hi! version 24.04.000.055

Code: Select all

=================================================
= OpenEMM Maintenance Tool (OMT) v24.04.000.066 =
=================================================
Root mode: On
Hostname: **********
Free diskspace: 81.9 % (of 49.24 GiB)
OpenEMM License: OpenEMM (ID: 0)
OpenEMM Runtime Version: 24.04.000.066
OpenEMM Version: 24.04.000.055
System-Url: https://*****************

Current menu: Show OpenEMM status

OpenEMM status:
Operating System (OS): Alma 9
Python version: 3.9.18
Mandatory system package 'MariaDB-server' is not installed
Mandatory system package 'MariaDB-common' is not installed
Mandatory system package 'MariaDB-client' is not installed
Mandatory system package 'MariaDB-shared' is not installed
Mandatory system package 'MariaDB-devel' is not installed
Optional system package 'galera' for MariaDB clusters is not installed
DBCFG: OK
Postfix Version: 3.5.9
Database client version: /usr/bin/mariadb  Ver 15.1 Distrib 10.5.22-MariaDB, for Linux (x86_64) using  EditLine wrapper
Database Connection: OK
System-Time: 2024-05-24 12:30:58
System-Time-DB: 2024-05-24 12:30:58
Database version: MariaDB 10.5.22-MariaDB
OpenEMM database structure exists (Version 24.01.698)
Database table emm_db_errorlog_tbl: OK
BirtURL configvalue: OK
Mailaddresses: OK
Jobqueue status: OK
DKIM keys available for domains: None
Java version: 17.0.2 (Oracle)
Tomcat version: 10.1.15.0
Wkhtml version: wkhtmltopdf 0.12.6 (with patched qt)
OpenEMM Application is running (Tomcat ProcessID: 3314, started at: 12:27 1:50)
OpenEMM Backend ok: once
OpenEMM Backend running: mailout, update, trigger, generate, pickdist, slrtscn, direct-path, bav-update, bavd, bav
Frontend application integrity: OK
Statistics application integrity: OK
Webservices application integrity: OK

maschoff
Site Admin
Posts: 2616
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Problems with some features after clean installation.

Post by maschoff »

So, what is your problem?
OpenEMM Maintainer
bonscot
Posts: 11
Joined: Tue Apr 16, 2024 9:44 pm

Re: Problems with some features after clean installation.

Post by bonscot »

See message viewtopic.php?p=19125#p19125

The problem that i have now is with generating previews and PDFs with Puppetee
maschoff
Site Admin
Posts: 2616
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Problems with some features after clean installation.

Post by maschoff »

Stack:
* AlmaLinux 9.3
* OpenEMM 24.04.000.055

Do you see any warnings when npm is executed during the update of OpenEMM?

Which version of puppeteer was installed by npm? (npm list puppeteer)
OpenEMM Maintainer
bonscot
Posts: 11
Joined: Tue Apr 16, 2024 9:44 pm

Re: Problems with some features after clean installation.

Post by bonscot »

Hi thanks!
Yes, i see...

Installing required dependencies:
npm WARN deprecated puppeteer@21.11.0: < 22.5.0 is no longer supported

added 124 packages, and audited 125 packages in 16s

11 packages are looking for funding
run `npm fund` for details

found 0 vulnerabilities
maschoff
Site Admin
Posts: 2616
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Problems with some features after clean installation.

Post by maschoff »

puppeteer 21.11.0 is fine. What is your problem?
OpenEMM Maintainer
bonscot
Posts: 11
Joined: Tue Apr 16, 2024 9:44 pm

Re: Problems with some features after clean installation.

Post by bonscot »

Solved. The problem was that I couldn't generate a PDF. By examining the logs, I saw that the issue was that Puppeteer couldn't access the server domain from localhost. OpenEMM listens on ports 8443 and 8080; from the outside, I had added a rule to redirect requests from ports 80 and 443 to ports 8080 and 8443, respectively. However, when I added that rule, I didn't include redirection for requests originating from localhost.

Tranks!
maschoff
Site Admin
Posts: 2616
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Problems with some features after clean installation.

Post by maschoff »

Thanks, I will add a hint to the Install & Admin Guide.
OpenEMM Maintainer
Post Reply