runtime-23.10.000.072 fails with tomcat native installation

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

JuergenB
Posts: 136
Joined: Thu Dec 05, 2019 9:03 pm

runtime-23.10.000.072 fails with tomcat native installation

Post by JuergenB »

The Beta Relase still doesn´t install tomcat native ..

for installation you need to compile 1.2.39

Code: Select all

cd /home/openemm/opt 
wget https://dlcdn.apache.org/tomcat/tomcat-connectors/native/1.2.39/source/tomcat-native-1.2.39-src.tar.gz
tar -C /home/openemm/opt  -xvzf tomcat-native-1.2.39-src.tar.gz
cd /home/openemm/opt/tomcat-native-1.2.39-src/native/
./configure --with-apr=/usr/bin/apr-1-config --with-ssl=yes --prefix=/home/openemm/opt/tomcat-native-1.2.39 --with-java-home=/usr/lib/jvm/java
make && make install
ln -s /home/openemm/opt/tomcat-native-1.2.39 /home/openemm/opt/tomcat-native
maschoff
Site Admin
Posts: 2591
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: runtime-23.10.000.072 fails with tomcat native installation

Post by maschoff »

Quote from the Install & Admin Guide:
To use OpenEMM with secure HTTPS connections, for Tomcat you should use the NIO Connector, because according to the Apache Foundation the APR/Native HTTP Connector is deprecated and will be removed in Tomcat 10.1 and later.
OpenEMM Maintainer
Post Reply