22.10.023 runtime, password required for updates & Application wont start at all

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

JuergenB
Posts: 136
Joined: Thu Dec 05, 2019 9:03 pm

22.10.023 runtime, password required for updates & Application wont start at all

Post by JuergenB »

Hi,

the runtime 22.10.023 asks for a password if try to install Tomcat during the basic environment setup.

Code: Select all

=============================================
= OpenEMM Maintenance Tool (OMT) v22.10.023 =
=============================================
Root mode: On
Hostname: localhost.localdomain
OpenEMM Runtime Version: 22.10.023
OpenEMM Version: Unknown
System-Url: Unknown

Invalid database vendor in dbcfg:
Database Connection cannot be established. (Maybe database user or database connection parameters for OpenEMM were not configured)
Database structure does not exist. (Maybe OpenEMM is not installed)
Basic webapplication configuration for Tomcat/CatalinaHome is missing or invalid. Please configure.

Current menu: Configure basic environment (Java, Tomcat, Tomcat-Native, Wkhtml, Proxy)

Current webapp basic configuration:
 JAVA_HOME:     /usr/lib/jvm/java-11-openjdk-11.0.18.0.10-2.el9_1.x86_64
 CATALINA_HOME: None
 Tomcat-Native: /home/openemm/opt/tomcat-native
 WKHTMLTOPDF:   None
 WKHTMLTOIMAGE: None
 PROXY:         None

Please choose entry to change (Blank => Back):
 > CATALINA_HOME
Please enter path for CATALINA_HOME (Blank => Skip configuration of existing Tomcat and install some):
 >
Do you want to install the included Tomcat application now? (Y/n, Blank => Yes):
 > y

Starting OpenEMM Update ...
Please enter password (Blank => Cancel):
can you please provide an installer in the future that has at least been tested for a default installation?

If you get past the installation and solved the problems with the password ...

OpenEMM still doesn´t start the Application... :roll: :roll: :roll:

Code: Select all

=============================================
= OpenEMM Maintenance Tool (OMT) v22.10.015 =
=============================================
Root mode: On
Hostname: localhost.localdomain
OpenEMM License: OpenEMM (ID: 0)
OpenEMM Runtime Version: 22.10.023
OpenEMM Version: 22.10.000.208
System-Url: http://emm.winpaccs.com

Current menu: Show OpenEMM status

OpenEMM status:
Operating System (OS): Alma 9
Python version: 3.9.14
Postfix Version: 3.5.9
Database client version: /usr/bin/mariadb  Ver 15.1 Distrib 10.5.16-MariaDB, for Linux (x86_64) using  EditLine wrapper
Database Connection: OK
System-Time: 2023-05-18 17:32:29
System-Time-DB: 2023-05-18 17:32:29
Database version: MariaDB 10.5.16-MariaDB
OpenEMM database structure exists (Version 23.01.436)
Database table emm_db_errorlog_tbl: OK
Jobqueue status: OK
DKIM keys available for domains: None
Java version: 11.0.18 (Oracle)
Tomcat version: 10.0.20.0
Tomcat-Native version: 1.2.36
Wkhtml version: wkhtmltopdf 0.12.6.1 (with patched qt)
OpenEMM Application is NOT running
OpenEMM Backend ok: once
OpenEMM Backend running: mailout, update, trigger, generate, mta, pickdist, slrtscn, direct-path, bav-update, bavd, bav, mlcontrol
I tried with AlmaLinux 9.1 and Runtime 22.04.008, here i can upgrade to Runtime 22.10.020 and i get this to work properly.

I tried today with Runtime 22.10.023, it doesn´t start the Application.
Installation seems fine.