cant connect OpenEMM Webservices / Fehler keine Verbindung

Use this forum for all questions related to the source code of OpenEMM

Moderator: moderator

Fredy
Posts: 6
Joined: Tue Jul 20, 2010 6:50 pm

cant connect OpenEMM Webservices / Fehler keine Verbindung

Post by Fredy » Tue Jul 20, 2010 10:42 pm

Vorweg ich bin im Thema Webservices ein Anfänger, daher bitte ich um Nachsicht falls ich etwas grundlegendes missverstanden habe.

Ich nutze die VM von openEMM auf Centos Basis.
Das WSDL File habe ich mit folgendem Aufruf generiert:

Code: Select all

./EmmCreateWSDL.sh -o ws.wsdl -l "192.168.178.28:8080/emm_webservice"
-n "urn:agnitas-webservice" -w ALL
org.agnitas.webservice.EmmWebService_Port
da ich im Forum den Hinweis gefunden habe hab ich es auch mit:

Code: Select all

./EmmCreateWSDL.sh -o ws.wsdl -l "192.168.178.28:8080/emm_webservice"
-n "192.168.178.28:8080/emm_webservice" -w ALL
org.agnitas.webservice.EmmWebService_Port
zur interaktion mit den Webservices nutze ich die Klasse von enarion.net für PHP.

Meine Fragen:
wo muss das ws.wsdl File liegen? wenn man es generiert liegt es im Ordner \webservices dieser Ordner ist aber nicht via HTTP erreichbar, oder? Deshalb habe ich die ws.wsdl datei immer lokal abgelegt oder in einen via Browser erreichbaren Ordner...

Hab ich ws.wsdl überhaupt mit den richtigen Parametern generiert, bzw. stimmen die Pfade, wie gesagt ich nutze die Centos VM.

Die Fehlermeldung die ich erhalte wenn ich versuche eine methode via Webservice auftzurufen:
  • Code: Select all

    SoapFault: Could not connect to host...
  • Code: Select all

    Fatal error: Maximum execution time of 60 seconds exceeded ....
meine Systemlandschaft sieht so aus:
Die VM mit OpenEMM hat die feste IP 192.168.178.28 der Host für die VM hat die ip z.B 192.168.178.2. Meine Entwicklungsumgebung liegt auf 192.168.178.2 sowie das PHP Script mit dem soapclient.

Der Test Soapclient EmmSoapClient.sh auf der VM funktioniert und liefert Ergebnisse.

Ich hoffe mir kann jemand weiterhelfen, dafür wäre ich sehr dankbar.

In english:
I anticipate in the Web services topic a beginner, so I apologize if I've misunderstood something fundamental.

I use the VM OpenEMM on Centos base.
The WSDL file I generated with the following call:

Code: Select all

. / EmmCreateWSDL.sh ws.wsdl-o-l "192.168.178.28:8080 / emm_webservice"
-N "urn: AGNITAS-webservice"-w ALL
org.agnitas.webservice.EmmWebService_Port
I have found the forum I'm pointing it with:

Code: Select all

. /-O EmmCreateWSDL.sh ws.wsdl-l "192.168.178.28:8080 / emm_webservice"
-N "192.168.178.28:8080 / emm_webservice"-w ALL
org.agnitas.webservice.EmmWebService_Port
for interaction with the Web services I use the class of enarion.net for PHP.

My questions:
where must be the ws.wsdl File? when it is generated it is in the folder \ webservices, this folder is not accessible via HTTP, right? I therefore ws.wsdl file stored locally or in a more accessible via browser folder ...

Did I ever ws.wsdl generated with the correct parameters, or vote the paths, as I said use the Centos VM.

The error message I get when I try a method auftzurufen via Web:

Code: Select all

 SoapFault: Could not connect to host ...

Code: Select all

Fatal error: Maximum execution time of 60 seconds exceeded ....


My system environment is as follows:
The VM has OpenEMM has a fixed IP 192.168.178.28 host for the VM ip as 192.168.178.2. My development is on 192.168.178.2 and soapclient the PHP script with the.

The test SoapClient EmmSoapClient.sh works on the VM and produces results.

I hope someone can help, I would be very grateful.

Fredy
Posts: 6
Joined: Tue Jul 20, 2010 6:50 pm

Post by Fredy » Wed Jul 28, 2010 7:04 pm

solved, login and password were wrong

gilbe
Posts: 1
Joined: Thu Oct 13, 2011 1:53 pm

Re: cant connect OpenEMM Webservices / Fehler keine Verbindu

Post by gilbe » Thu Oct 13, 2011 1:57 pm

My problem is fixed too.Thanks for such a detailed reply. Finally the miracle has happened. Someone could hel[p me:)) buy levitra online

Post Reply