bav does not forward emails according to bounce filter

Use this forum for all questions related to bounce management of OpenEMM

Moderator: moderator

sannc
Posts: 13
Joined: Tue Jul 01, 2008 1:23 pm
Location: Aschaffenburg

bav does not forward emails according to bounce filter

Post by sannc » Tue Jul 01, 2008 1:30 pm

Hi there!

I am almost finished with setting up OpenEMM on a Gentoo box with Postfix as MTA (--> sendmail disabled!). There is one thing which does not work properly yet: Emails to my bounce address (ext_1@openemm.mydomain.com) are not forwarded to the email address I entered as forward-to address.

I spent some time searching for my mistake and stumbled across the files in /home/openemm/var/spool/filter. There is a file called "sent-unspec" which contains all my missing test emails but none of them made it into my inbox.

Which logfile can I check or who can help me with this issue?

TIA
Carsten

maschoff
Site Admin
Posts: 2188
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Wed Jul 02, 2008 10:48 am

You must not use Postfix but the internal SMTP server of OpenEMM (which is automatically enabled is you disable Sendmail). Two MTAs on the same machine running at the same time will cause problems.
OpenEMM Maintainer

sannc
Posts: 13
Joined: Tue Jul 01, 2008 1:23 pm
Location: Aschaffenburg

Post by sannc » Wed Jul 02, 2008 12:43 pm

ma wrote:You must not use Postfix but the internal SMTP server of OpenEMM (which is automatically enabled is you disable Sendmail). Two MTAs on the same machine running at the same time will cause problems.
Ah ... ok. But there is no way to turn off postfix because this is a hosting machine which is not only used by OpenEMM. If I define a transport in Postfix which forwards all E-Mails to my bounce domain to the local SMTP server (8025), do I need to configure anything else than the bounce filters?

Best regards
Carsten

sannc
Posts: 13
Joined: Tue Jul 01, 2008 1:23 pm
Location: Aschaffenburg

Post by sannc » Wed Jul 02, 2008 12:55 pm

ma wrote:You must not use Postfix but the internal SMTP server of OpenEMM (which is automatically enabled is you disable Sendmail). Two MTAs on the same machine running at the same time will cause problems.
Next problem: I forwarded all email to my bounce domain to localhost:8025 and this works fine. Now I got a NDR back:

Code: Select all

Mail failed due to 510:
Unknown user ext_1@openemm.mydomain.com
The bounce filter for the address ext_1@openemm.mydomain.com is created and configured as autoresponder. The problem is the same when the bounce filter is configured as forwarder.

Any hints?

Best regards
Carsten

sannc
Posts: 13
Joined: Tue Jul 01, 2008 1:23 pm
Location: Aschaffenburg

Post by sannc » Tue Jul 08, 2008 9:16 am

*push*

sannc
Posts: 13
Joined: Tue Jul 01, 2008 1:23 pm
Location: Aschaffenburg

Post by sannc » Wed Jul 09, 2008 9:18 am

Hi!

I tried a little bit more and found the following in bav-update.log

Code: Select all

[09.07.2008  10:10:17] 3592 ERROR/data: Unable to read local-host-names (2, 'No such file or directory')
[09.07.2008  10:10:17] 3592 ERROR/data: Unable to read virtusertable (2, 'No such file or directory')
[09.07.2008  10:10:17] 3592 ERROR/data: Companys domain "openemm.mydomain.com" not found in mailertable
It seems as if OpenEMM tries to figure some sendmail specific things out although I disabled sendmail ... maybe this is a part of the problem?

Please take care of my problem ... I have almost a running system and this is the only thing which does not work yet :-(

Regards
Carsten

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Wed Jul 09, 2008 10:49 am

So first, you're right, bav-update still looks for some sendmail files (I tested it on a system with sendmail disabled, but sendmail installed, so I did not hit this problem.) The first line is critical, as the own domain won't be recognized:

Code: Select all

[09.07.2008  10:10:17] 3592 ERROR/data: Unable to read local-host-names (2, 'No such file or directory')
These two lines are annoying, but can safely be ignored:

Code: Select all

[09.07.2008  10:10:17] 3592 ERROR/data: Unable to read virtusertable (2, 'No such file or directory')
[09.07.2008  10:10:17] 3592 ERROR/data: Companys domain "openemm.mydomain.com" not found in mailertable
An (untested) short work around: edit the file /home/openemm/bin/scripts/bav-update.py and change the line 151 from

Code: Select all

if agn.iswin:
to

Code: Select all

if agn.iswin or True:
(please make sure to not change the indention of the code!) To get rid of the other two messages, you can change line 192 the same way.

In the next release, a proper fix will be included.

-- ud

sannc
Posts: 13
Joined: Tue Jul 01, 2008 1:23 pm
Location: Aschaffenburg

Post by sannc » Wed Jul 09, 2008 11:12 am

Thank you for the quick reply. There is still one error message left:

Code: Select all

[09.07.2008  12:03:24] 23419 ERROR/data: Companys domain "openemm.mydomain.com" not found in mailertable
For sure OpenEMM does not know my domain name if it tries to look it up in the mailertable. But when I disable sendmail it needs to get to know it from somewhere else ... the corresponding field in the company_tbl is filled with "openemm.mydomain.com".

So I still have the problem that the Forwarder I set up in Bounce filters does not work because the built in SMTP server says:

Code: Select all

Mail failed due to 510:
Unknown user ext_2@openemm.mydomain.com
:-(

Regards
Carsten

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Wed Jul 09, 2008 1:49 pm

Have you restarted OpenEMM? Otherwise the code change won't show any effect.

-- ud

sannc
Posts: 13
Joined: Tue Jul 01, 2008 1:23 pm
Location: Aschaffenburg

Post by sannc » Wed Jul 09, 2008 1:50 pm

Sure :-) And the code change does show effect ... two messages are gone but the one I posted remains ...

Regards
Carsten

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Wed Jul 09, 2008 3:49 pm

Ahh, okay, the message is misleading, the problem is that now only the local host name is considered as known domain, so if openemm.mydomain.com is not the name of your system, this won't work. You can set this domain in line 130, just replace localhost with openemm.mydomain.com (keep the apostrophs.)

In the next version the domain is read from the database, so these quirks are no more necessary.

-- ud

sannc
Posts: 13
Joined: Tue Jul 01, 2008 1:23 pm
Location: Aschaffenburg

Post by sannc » Wed Jul 09, 2008 5:41 pm

... and that's the solution! Now I am a happy user who runs OpenEMM on a Gentoo Linux Box with Postfix :-) The only thing I have to fix is the immediate bounce detection by slrtscan ...

Regards
Carsten

Post Reply