Problem with bav.rc

Use this forum for all questions related to bounce management of OpenEMM

Moderator: moderator

Fabi
Posts: 6
Joined: Fri Mar 09, 2007 7:57 pm
Location: /germany/bavaria

Problem with bav.rc

Post by Fabi » Fri Mar 23, 2007 4:21 pm

Hi everybody,

im using
- Debian Etch 4.0
- Sendmail 8.13.8-3
- OpenEMM 5.0.2

I tried to get the bounce management work but i get a bounce with the following error:

Code: Select all

The original message was received at Fri, 23 Mar 2007 16:06:46 +0100
from static.88-198-118-182.clients.your-server.de [88.198.118.182]

   ----- The following addresses had permanent fatal errors -----
ext_1@bounce.domain.com
    (reason: Can't create output)

   ----- Transcript of session follows -----
550 5.0.0 ext_1@bounce.domain.com... Can't create output
This is my relay-domains:

Code: Select all

bounce.domain.com
My mailertable:

Code: Select all

bounce.domain.com      procmail:/home/openemm/conf/bav/bav.rc
My bav.conf:

Code: Select all

@bounce.domain.com        accept:rid=local
ext_1@bounce.domain.com accept:rid=1,cid=1,fwd=sebastian@personal-domain.com
Snippet from the logfile:

Code: Select all

Mar 23 16:06:51 domain sendmail[31557]: l2NF65SB031557: from=fabian@personal-domain.com, size=7, class=0, nrcpts=1, msgid=<200703231506.l2NF65SB031557@mail.domain.com>, proto=ESMTP, daemon=MTA-v4, relay=static.88-198-118-182.clients.your-server.de [88.198.118.182]
Mar 23 16:06:51 domain sendmail[31557]: l2NF65SB031557: Milter add: header: X-AGNMailloop: from=fabian@personal-domain.com,rid=1,cid=1,fwd=sebastian@personal-domain.de,to=ext_1@bounce.domain.com
Mar 23 16:06:51 domain sendmail[31557]: l2NF65SB031557: Milter add: header: X-AGNLoop: set
Mar 23 16:06:51 domain sendmail[31562]: l2NF65SB031557: to=ext_1@bounce.domain.com, delay=00:00:05, xdelay=00:00:00, mailer=procmail, pri=120007, relay=/home/openemm/conf/bav/bav.rc, dsn=5.0.0, stat=Can't create output
Mar 23 16:06:51 domain sendmail[31562]: l2NF65SB031557: l2NF6pSB031562: DSN: Can't create output
Mar 23 16:06:51 domain sendmail[31562]: STARTTLS=client, relay=smtp.personal-domain.com., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Mar 23 16:06:51 domain sendmail[31562]: l2NF6pSB031562: to=fabian@personal-domain.com, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=30000, relay=smtp.personal-domain.com. [85.10.193.150], dsn=2.0.0, stat=Sent (Ok: queued as 5A3E9AAC00B)
Does anybody know why i get this strange DSN: Can't create output??

Regards
Fabian

syscol
Posts: 4
Joined: Mon Mar 19, 2007 4:21 pm

Post by syscol » Mon Mar 26, 2007 3:14 pm

Hello,

Have you read this topic :

http://www.openemm.org/forums/ftopic156.html

Fabi
Posts: 6
Joined: Fri Mar 09, 2007 7:57 pm
Location: /germany/bavaria

Post by Fabi » Mon Mar 26, 2007 3:58 pm

hi,

yes, i've read the topic, but i had these symlinks already

regards
fabian

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Tue Mar 27, 2007 1:00 pm

Is the file ~openemm/conf/bav/bav.rc owned by root and has only read-/writepermission set for the owner? Is bavd.py running?

-- ud

Fabi
Posts: 6
Joined: Fri Mar 09, 2007 7:57 pm
Location: /germany/bavaria

Post by Fabi » Tue Mar 27, 2007 1:32 pm

I think the permessions are ok:

Code: Select all

-rw------- 1 root root 1303 2006-09-19 13:53 /home/openemm/conf/bav/bav.rc
But i dont have such a process, my processes with 'bav' are:

Code: Select all

openemm  30855  0.0  0.5  10300  5868 ?        S    Mar23   0:00 python /home/openemm/bin/scripts/bav-update.py
openemm  30881  0.0  0.4   8664  4628 ?        S    Mar23   0:00 python /home/openemm/bin/scripts/bav-trigger.py
openemm  30909  0.0  0.0  18068   644 ?        Sl   Mar23   0:00 /home/openemm/bin/bav -L INFO
Regards
Fabian

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Tue Mar 27, 2007 1:38 pm

This may be the problem, please check the logfile for bavd for possible error messages (~openemm/var/log/*-bavd.log), thanks!

-- ud

Fabi
Posts: 6
Joined: Fri Mar 09, 2007 7:57 pm
Location: /germany/bavaria

Post by Fabi » Tue Mar 27, 2007 1:43 pm

Great!

Thanks for the hint.

I don't know why the bavd wasnt running, but after starting it by hand with bavd.sh start it seems that the message is now processed.

Now i restarted openemm and now it seems that bavd is running:

Code: Select all

openemm  14749  0.0  0.5  10304  5804 pts/1    S    14:38   0:00 python /home/openemm/bin/scripts/bav-update.py
openemm  14775  0.0  0.4   8656  4624 pts/1    S    14:38   0:00 python /home/openemm/bin/scripts/bav-trigger.py
openemm  14801  0.0  0.4   9136  5016 pts/1    S    14:38   0:00 python /home/openemm/bin/scripts/bavd.py
openemm  14803  0.0  0.0   9872   520 pts/1    Sl   14:38   0:00 /home/openemm/bin/bav -L INFO
Now im able to test and configure the bounce filter.

Regards
Fabian

Post Reply