Bounce management

Use this forum for all questions related to bounce management of OpenEMM

Moderator: moderator

trax
Posts: 27
Joined: Fri Dec 15, 2006 9:53 pm
Location: Munich

Bounce management

Post by trax » Sat Dec 30, 2006 12:54 am

Hello OpenEMM Community!

Unfortunetly my OpenEMM bounce management does not work.

OpenEMM works fine - no problems. Also all log-files are clean - no failures.


I've seen the posts which descirbe the two different bounce systems.

In my case I have the following configuration:

OpenEMM runs on a VPS machine.
It is the only system running on.

I have a separate domain for it. It's calles company.com

This domain ist managed by my hoster. But I can create subdomains.

A Records:
company.com 123.123.123.123 (sample ip of the server)
mail.company.com 123.123.123.123
bounce.company.com 123.123.123.123
www.bounce.company.com 123.123.123.123

MX Records:
bounce.company.com pref 30
mail.company.com pref 20


I have a maillog-file in /var/log/ which notices all the mail activities.
I have only the standard email-addresses which belong to the user root an on e-mail-addresss called norely@company.com, which is the address the mails are sent from. These emails belong to the user mailuser.

When I send e-mails to an non existing e-mail-address with openemm, the mails are bouncing. The emails go into /var/mail/mailuser.
In the maillog is logged:

Code: Select all

Dec 28 22:59:44 server sendmail[16216]: STARTTLS=client, relay=mail.recipient.de., version=TLSv1/SSLv3, verify=FAIL, cipher=AES256-SHA, bits=256/256
Dec 28 22:59:44 lvps87-230-17-142 sendmail[16216]: 00001100000000023: to=<test@recipient.de>, ctladdr=<noreply@company.com> (1001/100), delay=00:00:09, xdelay=00:00:02, mailer=esmtp, pri=0, relay=mail.recipient.de. [82.98.78.233], dsn=5.1.1, stat=User unknown
Dec 28 22:59:44 server sendmail[16216]: 00001100000000023: kBSLxf1t016216: DSN: User unknown
As in the bav-rule defined, this is a bounce.
Why does openemm not regognize this? Not a single bounce is listed.

------------------

Now I get a second problem.

I sometimes get the message:
... sendmail[9892]: kBTJMjjf009892: ruleset=check_rcpt,... Relaying denied. Proper authentication required.


Is this a failure in my configuration?

I am using a brand new Suse 10.0 with sendmail


Thanks for your suggestions!

Best regards

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Wed Jan 03, 2007 2:16 pm

The first case should be handled by slrtscn.py, be sure it is running and it has read access to the mail log file.

The second case may be a missing relay entry in /etc/mail/relay-domains. Make sure that all modifications are made in /etc/mail as written in the installation documentation.

-- ud

trax
Posts: 27
Joined: Fri Dec 15, 2006 9:53 pm
Location: Munich

Post by trax » Fri Jan 05, 2007 12:11 am

Hello ud!

slrtscn.py is running.

He today's logfile:

Code: Select all

[04.01.2007  02:01:42] 16044 INFO/loop: -- MARK --
[04.01.2007  05:01:50] 16044 INFO/loop: -- MARK --
[04.01.2007  08:01:53] 16044 INFO/loop: -- MARK --
[04.01.2007  11:01:57] 16044 INFO/loop: -- MARK --
[04.01.2007  14:02:07] 16044 INFO/loop: -- MARK --
[04.01.2007  17:02:10] 16044 INFO/loop: -- MARK --
[04.01.2007  20:02:14] 16044 INFO/loop: -- MARK --
[04.01.2007  23:02:22] 16044 INFO/loop: -- MARK --
[04.01.2007  23:50:19] 16044 INFO/main: Going down
[04.01.2007  23:50:44] 17955 INFO/main: Starting up
I've got Suse 10 and there is a different configuraton than in the install doc.

I only got /etc/syslog.conf

There I changed a line:

Code: Select all

mail.*                          -/var/log/maillog
But there is no entry like
"options { long_hostnames(off); sync(0); perm(0644); stats(3600); };
"

So I changed the access by myself.
The file /var/log/maillog is at 0777.

-------------------------------------------------------

I think I got a general problem:

As I wrote, the Domains are managed at my Hosting Company.
I can set A and MX Records. But not in the way as you described.

The current configuration:

A Records:
company.com 123.123.123.123 (sample ip of the server)
mail.company.com 123.123.123.123
bounce.company.com 123.123.123.123
www.bounce.company.com 123.123.123.123

MX Records:
bounce.company.com pref 30
mail.company.com pref 20


My /etc/mail/relay-domains:

Code: Select all

company.com
mail.company.com
I use email-addresses like noreply@company.com


What I'm doing wrong?

trax
Posts: 27
Joined: Fri Dec 15, 2006 9:53 pm
Location: Munich

Post by trax » Sat Jan 06, 2007 5:36 pm

Hello,

I now installed the syslog-n package for Suse 10.

Now i could change the lines at the /etc/syslog-ng/syslog-ng.conf.in


But unfortunatly the bounce management does not work anyway.

Any ideas?

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Fri Jan 12, 2007 4:00 pm

Ok, assuming the name of your machine is company.com, you can use sender addresses like noreply@bounce.company.com. You can add more subdomains, if you prefer, but add them to /etc/mail/relay-domains and /etc/mail/mailertable (and run make.) To forward the sender address to your bounce filter, you can create a file ~openemm/conf/bav/bav.conf-local and add this line:

Code: Select all

noreply@bounce.company.com alias:ext_1@bounce.company.com
Wait until bav-update.py has added this to ~openemm/var/spool/bav/bav.conf and then retry it.

-- ud

trax
Posts: 27
Joined: Fri Dec 15, 2006 9:53 pm
Location: Munich

Post by trax » Fri Jan 12, 2007 7:03 pm

Sorry I really don't get it!

My bav.conf:

Code: Select all

@company.com     accept:rid=local
noreply@company.com alias:ext_1@company.com
My mailertable:

Code: Select all

company.com      procmail:/home/openemm/conf/bav/bav.rc
My relay-domains:

Code: Select all

company.com

I did not create a user or alias ext_1 in the sendmail conf.

What am I doing wrong?

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Fri Jan 19, 2007 9:20 am

ext_1@... is the first bounce filter you create in OpenEMM. Every further gets a new number, ext_2, ext_3, etc. So create this bounce filter in OpenEMM, then you should get an additional line in bav.conf like:

Code: Select all

ext_1@bounce.company.com      accept:rid=1,cid=1,fwd=me@company.com
Do not use your regular hostname, company.com, for the bounce management.

-- ud

Post Reply