Page 1 of 1

Normal file attachment size

Posted: Tue Sep 02, 2008 2:57 pm
by BG
Hi All,

I found this in the documentation:
1. There is also a difference between the Original size and the Size in e-mail. The reason is that the software converts the file attachment into a sendable format (ASCII-Format) which is about 30 to 40 per cent larger than the original format.
2.Please be aware that the maximum file size is 1 MByte (due to the default settings of the MySQL database for BCOB data fields).

But I'm unable to attach a 448Kb PDF file because I receive "The file you want to upload exceeds the maximum file size for attachments." error.
If I put this pdf into zip it accepts the attachment.

Why it accept the compressed file?
How can I increase the attachment's size?
Can I change the data tpye of the field in the opemm's database to Large BLOB?
Thank you in advance


Posted: Fri Sep 05, 2008 2:10 pm
by BG

There is no plan to change this field in the database?
Is this by design?
Thank you

Posted: Fri Sep 05, 2008 2:54 pm
by maschoff
We don't know if this is a bug in MySQL, but it behaves differently if you store a PDF file instead of a file with a different format.

You can change the code to set the limit higher but we know from experience that in this case at least some versions of MySQL will cause an exception.


Posted: Fri Sep 05, 2008 3:10 pm
by BG
Hi Ma,

Thank you for your answer.
Which file shall I change?

Posted: Mon Sep 08, 2008 6:49 am
by Nse
Hi BG,

You should change the file MailingAttachmentsAction in org.agnitas.web.



Posted: Mon Sep 08, 2008 8:08 am
by BG
Thank you NSE!

Posted: Thu Sep 30, 2010 1:08 pm
by MartinBerlin
Dear all

I am very surprised. This thread is now more than two years old and still the constraint about pdf attachment size is in place?

Otherwise, I think, OpenEMM is a very sophisticated application, but a mailing software with attachment constraints like this renders itself useless to a certain degree. Don't you agree?

Re: Normal file attachment size

Posted: Mon Apr 04, 2011 3:59 pm
by mmenke
Since OpenEMM 6.2 you can change the maximum size for attachments in the file.
You find it here: /home/openemm/webapps/core/WEB-INF/classes/

Please note, that you should also check your MySQL my.cnf (/etc/my.cnf) for the max_allowed_packet setting.
In my case, OpenEMM / Java threw a nice error: java.lang.IllegalStateException: forward() not allowed after buffer has committed.

Increasing the MySQL setting helped to fix this:

# for openemm

Then just restart MySQL (/etc/init.d/mysql restart).

Hope this helps. I'm updating this old thread, because the info is missing here and the feature is pretty new.