runtime error 21.10.009 at installation

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

JuergenB
Posts: 72
Joined: Thu Dec 05, 2019 9:03 pm

runtime error 21.10.009 at installation

Post by JuergenB » Mon Oct 04, 2021 7:06 pm

Hi,

openemm-runtime-21.10.009 has a installation error.
After i start OMT.sh at user openemm i want to configure the basic environment.

Runtime 21.04.099 is fine, but the new one is ugly ...

All if fine, but if i enter Tomcat-Native the Script fails.

Has anyone tested the runtime 21.10.009 ?
=============================================
= OpenEMM Maintenance Tool (OMT) v21.10.009 =
=============================================
Hostname: localhost.localdomain
OpenEMM Runtime Version: 21.10.009
OpenEMM Version: Unknown
System-Url: Unknown

Current configuration changes or updates need the OpenEMM system to be restarted.

Current menu: Configure basic environment (Java, Tomcat, Tomcat-Native, Wkhtml, Proxy)

Current webapp basic configuration:
JAVA_HOME: /usr/lib/jvm/java-11-openjdk-11.0.12.0.7-0.el8_4.x86_64
CATALINA_HOME: /home/openemm/opt/tomcat
Tomcat-Native: None
WKHTMLTOPDF: /usr/local/bin/wkhtmltopdf
WKHTMLTOIMAGE: /usr/local/bin/wkhtmltoimage
Proxy: None

Please choose entry to change (Blank => Back):
> Tomcat-Native
NameError: name 'currentTomcatNative' is not defined
AND

if restart ./OMT.sh after this error, the script fails again
Checking python installation ...
Python version found: 3.8.6
Checking Zip installation ...
Zip version 3.0 found
Starting python ...
AttributeError: 'NoneType' object has no attribute 'split'

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: runtime error 21.10.009 at installation

Post by maschoff » Wed Oct 06, 2021 2:56 pm

21.10 is still in beta. Please wait for later runtime and OpenEMM versions to be released or switch back to 21.04.
OpenEMM Maintainer

Post Reply