empty Dashboard on EMM Fall 2020

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

ryckmx
Posts: 4
Joined: Sun Jan 24, 2021 7:57 pm

empty Dashboard on EMM Fall 2020

Post by ryckmx » Tue Jan 26, 2021 3:16 pm

After applying some pending sql updates I just get now an empty Dashboard.

On the left side menu I only get this options:
Mediapool, Layout Builder, Push notifications, Administration and my user info, CompanyID:1, 20.10.000.107

Same for all admin users. Looks like some admin settings were updated for admin group? How could I get back?

Unfortunately I can't get a DB backup since I get permission errors using OMT.sh:

DB user needs grant 'SELECT ON mysql.proc' to backup db data. (e.g. GRANT SELECT ON mysql.proc TO 'openemm'@'%';)
Cannot create database backup

MariaDB [mysql]> show grants for openemm;
+-------------------------------------------------+
| Grants for openemm@% |
+-------------------------------------------------+
| GRANT RELOAD ON *.* TO `openemm`@`%` |
| GRANT SELECT ON `mysql`.`proc` TO `openemm`@`%` |
+-------------------------------------------------+
2 rows in set (0.000 sec)


Thank you in advice,

RR

maschoff
Site Admin
Posts: 2493
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: empty Dashboard on EMM Fall 2020

Post by maschoff » Tue Jan 26, 2021 4:57 pm

Are you sure that no SQL update is missing? If you check sub-menu system status of menu administration, do you see any missing DB updates?
OpenEMM Maintainer

ryckmx
Posts: 4
Joined: Sun Jan 24, 2021 7:57 pm

Re: empty Dashboard on EMM Fall 2020

Post by ryckmx » Tue Jan 26, 2021 5:35 pm

It was after all pending updates were applied that the Status was finally shown as green OK. Everything seems to be working just fine. Now I only see "User log" under Administration submenu.

What I see is admin_group_permission_tbl table is empty. Is there a way to reconstruct it? looks like some upgrade delete all contents after adding the permission_name field. What other tables could have been affected?

ryckmx
Posts: 4
Joined: Sun Jan 24, 2021 7:57 pm

Re: empty Dashboard on EMM Fall 2020

Post by ryckmx » Tue Jan 26, 2021 6:10 pm

Based on userrights.sql I updated the admin_group_permission_tbl and admin_permission_tbl. Still no changes to my admin user.

Then I added same admin_permission_tbl records of user 1 to my other admin users and now I'm able to see all modules successfully. :D

System Status show overall and db updates all in green again.

Hope nothing else is broken by now and that this helps somebody else.

Thank you.

ryckmx
Posts: 4
Joined: Sun Jan 24, 2021 7:57 pm

Re: empty Dashboard on EMM Fall 2020

Post by ryckmx » Wed Jan 27, 2021 12:54 am

I've also found an extra update:

insert into admin_to_group_tbl (admin_id,admin_group_id) values (2,1) ;

The above is required since the user must belong to at least one user group.

Post Reply