Stop Sending not working / Schedule emails not sending

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

alanhenry
Posts: 2
Joined: Mon Sep 07, 2020 9:12 pm

Stop Sending not working / Schedule emails not sending

Post by alanhenry » Mon Sep 07, 2020 9:17 pm

Hi All

Running 20.04.000.155 here.

We've had two major issues with this release and are wondering if anyone else has any similar experiences or possible solutions.

1) The stop delivery button doesn't work here. We're running our SMTP on another server, don't know if that is impacting that functionality.

2) Scheduled emails don't seem to trigger and send after generating. Sending one immediately after adding it in works fine though.

Wondering if anyone has experience something similar or has any tips.

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Stop Sending not working / Schedule emails not sending

Post by maschoff » Wed Sep 09, 2020 11:20 am

re 1: Please be a little bit more specific what you mean with "doesn't work".

re 2: Is you user time zone and the server time zone correct? is trigger process generate3.py up and running? Do you see any related entries in the maillog?
OpenEMM Maintainer

alanhenry
Posts: 2
Joined: Mon Sep 07, 2020 9:12 pm

Re: Stop Sending not working / Schedule emails not sending

Post by alanhenry » Wed Sep 09, 2020 2:51 pm

1) by not working I mean pressing that button doesn’t do anything - and same for Stop Generating. Both processes just continue regardless of what we do there. Seems there is no way to stop it.

2) user/server time zone are all correct. I don’t see the generate3.py process here - any idea how to start it?

Our cron file:

[root@ip-172-31-75-48 cron]# vi openemm

10 2 * * * /home/openemm/bin/janitor.sh openemm
45 20 * * * /home/openemm/bin/bouncemanagement.sh
~                                                                                        
~                                                                                        
~                                                                                        
~

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Stop Sending not working / Schedule emails not sending

Post by maschoff » Wed Sep 09, 2020 3:15 pm

1.) If you try to stop a mailing less than an hour before sending time it is already in production and will not work.

2.) generate3.py is a backend process and launched when you restart OpenEMM.
OpenEMM Maintainer

perun
Posts: 9
Joined: Wed Dec 04, 2019 12:39 pm

Re: Stop Sending not working / Schedule emails not sending

Post by perun » Thu Sep 10, 2020 2:19 pm

Hi,

We are having a weird problem with undo_mailing_tbl queries:
2020-09-09 17:03:07,437: ERROR [https-openssl-apr-8443-exec-19] com.agnitas.emm.core.JavaMailServiceImpl - Error sending email via xxxx: Invalid Addresses
emailSubject: EMM Error (Server: xxxxxxxx / Exceptiontype: CannotGetJdbcConnectionException)
emailContent: SQL: SELECT max(undo_id) AS last_undo_id FROM undo_mailing_tbl WHERE mailing_id = ?
Parameter: 0
Exception:
CannotGetJdbcConnectionException:
Could not get JDBC Connection; nested exception is java.sql.SQLException: Data source is closed

Is that something that could be affecting undo functionality?

I think our jdbc-connect and jdbc-driver properties are configured correctly, we didn't notice any problems anywhere else.

Thanks,

Matt

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Stop Sending not working / Schedule emails not sending

Post by maschoff » Fri Sep 11, 2020 1:17 pm

The cause is not the database table, but the missing database connection.
OpenEMM Maintainer

Post Reply