OpenEMM 19/20: Generating online archive throws error

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

svewap
Posts: 8
Joined: Wed Jun 10, 2020 12:55 pm
Contact:

OpenEMM 19/20: Generating online archive throws error

Post by svewap » Wed Jun 10, 2020 1:14 pm

Hi,
I'm trying to generate the online archive for mailings. I used the manual to create the action and form.
If I call the form with https://<url>/form.do?agnCI=1&agnFN=archive_overview OpenEMM goes into the error state. I tried it first with OpenEMM 19, then i updated to 20, but the problem still exists. Since no more precise error code is output (in emm_error.log file), unfortunately no approach for a solution can be found.

Code: Select all

2020-06-10 13:05:16,251: ERROR [http-nio-8080-exec-20] com.agnitas.userform.bean.impl.UserFormImpl - Action Error: CompanyID=1, ActionID=8, error codes=[]
Could the error output be improved?

Thanks, Sven

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: OpenEMM 19/20: Generating online archive throws error

Post by maschoff » Wed Jun 10, 2020 4:46 pm

At first, we will check for a bug.
OpenEMM Maintainer

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: OpenEMM 19/20: Generating online archive throws error

Post by maschoff » Mon Jun 15, 2020 1:46 pm

You may simply link the archive with [agnFORM name="archive_overview"] in your mailing.

In the URL you posted the agnUID is missing.
OpenEMM Maintainer

svewap
Posts: 8
Joined: Wed Jun 10, 2020 12:55 pm
Contact:

Re: OpenEMM 19/20: Generating online archive throws error

Post by svewap » Tue Jun 16, 2020 9:38 pm

maschoff wrote:
Mon Jun 15, 2020 1:46 pm
In the URL you posted the agnUID is missing.
Hi maschoff,
I didn't want to generate a link to a single archived mailing by using the agnUID . I want the overview. So I'm using the link of the backend.
Image

But using the agnUID parameter throws an error too:

Code: Select all

https://domain/form.do?agnCI=1&agnFN=archive_overview&agnUID=116
OpenEMM goes into error state, if calling the url: "Ein Fehler ist aufgetreten".

Image

Code: Select all

2020-06-16 22:29:20,274: ERROR [http-nio-8080-exec-4] com.agnitas.userform.bean.impl.UserFormImpl - Action Error: CompanyID=1, ActionID=8, error codes=[]
In this context it would be great if you could specify the error output.

Hofmann M.
Posts: 22
Joined: Thu Aug 03, 2006 3:18 pm
Location: Ruhpolding, BY, Germany
Contact:

Re: OpenEMM 19/20: Generating online archive throws error

Post by Hofmann M. » Wed Jun 17, 2020 7:13 am

Hello svewap,

maybe i can help.
The agnUID is required to provide details for the archive action (e.g. mailing list, recipient). The agnUID can also be generated with ##AGNUID##, so your link would be like this:

Code: Select all

http://....../form.do?agnCI=1&agnFN=archive_overview&agnUID=##AGNUID##
This link can now be used in a mailing and takes the user to the desired overview page.
The UID is also required to generate the personalized and, if necessary, individualized version of the recipient in the individual views. Setting a value manually for the agnUID is wrong, because this value is generated individually by the OpenEMM system.

If you want to use the link on a website, you can create a dummy receiver and use this measurable link on the website via the preview.

In the DT element, a "-sign is missing at the end, please add this (this is also wrong in the manual).

Code: Select all

...$archiveListUids.get($mailing)">...
We do not yet receive error codes at this point because no recipient can be identified.

Post Reply