Temporary tables never cleaned

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

mkalen
Posts: 33
Joined: Tue Jan 20, 2009 7:51 pm

Temporary tables never cleaned

Post by mkalen » Mon Feb 16, 2009 7:57 pm

Hello,
I use OpenEMM 5.5.1 with MySQL on Windows and I notice an increasing number of tables in the OpenEMM database named with a "TMP_CRT_" prefix.

Whenever I click "Send test mails to the administrators", "Send test mails to the test recipients", "Send mailing now" or use the WebService sendMailing method a new table is added.

Is there a "done()" call missing somewhere in the code?

legesund
Posts: 3
Joined: Thu Apr 26, 2007 10:39 am

Experiencing the same bug

Post by legesund » Tue Feb 17, 2009 10:09 am

With my installation I'm experiencing the same bug,
the OpenEMM database now contains more than 600 tables.
I'm not 100% percent sure, but this seems to have started
only after the last auto-upate to OpenEMM 5.5.1

Server Version: 5.0.32-Debian_7etch8-log
MySQL-Client-Version: 5.0.32

mkalen
Posts: 33
Joined: Tue Jan 20, 2009 7:51 pm

Re: Experiencing the same bug

Post by mkalen » Tue Feb 17, 2009 10:29 am

legesund wrote:Server Version: 5.0.32-Debian_7etch8-log
MySQL-Client-Version: 5.0.32
More info about my testing environment:
  • First-time install of OpenEMM 5.5.1 (no auto-upgrade)
  • MySQL Server v5.0.67 (Community Edition)
  • Sun JRE 6.0u11
  • Windows XP (SP3)

lord_alan
Posts: 80
Joined: Wed Oct 01, 2008 1:15 pm
Location: Farnham, Surrey. UK
Contact:

Post by lord_alan » Fri Feb 27, 2009 2:58 pm

I see this too.

OpenEMM 5.5.1 on Linux.

maschoff
Site Admin
Posts: 2390
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Mon Mar 02, 2009 4:10 pm

Actually, the tables should be dropped from time to time. We will look into this issue.
OpenEMM Maintainer

vag11
Posts: 1
Joined: Wed Nov 25, 2009 8:53 am

Post by vag11 » Wed Nov 25, 2009 8:58 am

Hi, any news about this? I am one step before updating to the new version 6 and I wonder is it safe to manually drop all those TMP_CRT_* tables?

maschoff
Site Admin
Posts: 2390
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Wed Nov 25, 2009 9:12 am

Yes you can. This bug is fixed in 6.0 (see CHANGELOG.txt). You can drop those tables (see new install guide, section 5.3).
OpenEMM Maintainer

Post Reply