Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Use this forum to report bugs and to check for bugfixes and new releases of OpenEMM

Moderator: moderator

wehsemann
Posts: 5
Joined: Tue Aug 25, 2020 7:50 am

Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by wehsemann » Tue Aug 25, 2020 7:54 am

Hello,

I'm getting the error HTML tag (div, a, etc) not allowed in the mailing wizard even if I'm on the WYSIWYG editor and using for alternative Text a separate field.
When I'm in the Standard Mailing editor view then it is working well and I can send emails. What is wrong in the wizard?

Thank's in advance.
Wendy

maschoff
Site Admin
Posts: 2401
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by maschoff » Wed Aug 26, 2020 8:56 am

Please post the code snippet and the step in the mailing wizard that creates the error when using it.
OpenEMM Maintainer

wehsemann
Posts: 5
Joined: Tue Aug 25, 2020 7:50 am

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by wehsemann » Fri Aug 28, 2020 6:34 am

Hello, this is the code:

Code: Select all

<div>
	Please click here to unsubscribe: <a href="https://www.test.com/newsletter/?lang=en&action=revoke" target="_blank">unsubscribe newsletter</a></div>
<div>
	Masthead: test GmbH | test | 12345 Berlin</div>
<div>
	Contact: <a href="mailto:info@test.com">info@test.com</a></div>
This is the error message:
HTML tag 'div' not allowed
HTML tag 'a' not allowed
Attribute 'href' not allowed for HTML tag 'a'
Attribute 'target' not allowed for HTML tag 'a'

Very weired because I can add a tags with the WYSIWYG editor and in the standard-Form to create new mailings it is working fine. In the old version of OpenEMM it is working as well in the wizzard mode.

Thank's in advance
Wendy

maschoff
Site Admin
Posts: 2401
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by maschoff » Fri Aug 28, 2020 10:22 am

I could not reproduce your problem with your code in 20.04.000.185.

But maybe I understand "I use for alternative Text a separate field. "? What do you mean exactly? Please explain step by step.
OpenEMM Maintainer

wehsemann
Posts: 5
Joined: Tue Aug 25, 2020 7:50 am

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by wehsemann » Wed Sep 02, 2020 7:04 am

Hello,
it means that for every text module I have an alternative module for text only. But this does not help.
Can this be a problem of the installation of the server? We had intially some problems because the installation guide is not without errors.

maschoff
Site Admin
Posts: 2401
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by maschoff » Wed Sep 02, 2020 8:50 am

Please tell us the errors in the install guide so that we can improve it. Without knowing the errors I can not assess the situation.
OpenEMM Maintainer

hostmaster
Posts: 3
Joined: Thu Sep 10, 2020 10:03 am

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by hostmaster » Thu Sep 10, 2020 10:22 am

maschoff wrote:
Wed Sep 02, 2020 8:50 am
Please tell us the errors in the install guide so that we can improve it. Without knowing the errors I can not assess the situation.
Dear mod or maintainer,
I post on behalf of user wehsemann, as i am the one who installs openemm 20.04 Centos 8

Logfile /home/openemm/tomcat9/logs/localhost.2020-08-25.log
https://pastebin.com/yrvRJd7P

According to Your question to the errors in the install guide of openemm 20.04. i did change the following steps contrary to the guid:

Fixes for errors in admin_guide PDF:

fix wkhtmltox error creating images install latest release wkhtmltox-0.12.6 on page 20 chapter 4.5

#dnf search wkhtmltox
#dnf info wkhtmltox.x86_64
#dnf install wkhtmltox.x86_64

same as https://github.com/wkhtmltopdf/packagin ... x86_64.rpm but from distribution maintainer

fix Apache Native Connector compile error on page 40

#dnf config-manager --enable PowerTools
#dnf install glibc-static redhat-rpm-config

#wget http://archive.apache.org/dist/tomcat/t ... src.tar.gz
#tar -xvzf tomcat-native-1.2.24-src.tar.gz
#cd tomcat-native-1.2.24-src/native/
#./configure --with-apr=/usr/bin/apr-1-config --with-ssl=yes --prefix=/home/openemm/opt/tomcat-native-1.2.24 --with-java-home=/usr/lib/jvm/java
#make install clean
#ln -s /home/openemm/opt/tomcat-native-1.2.24 /home/openemm/opt/tomcat/tomcat-native

now it is possible to execute openssl TLS with the APR connector for Tomcat´s server.xml as described on page 41
fix for systemd openemm service automtic start

# nano /etc/systemd/system/openemm.service

[Unit]
Description=OpenEMM startup script
After=var-run.mount network.target local-fs.target time-sync.target sendmail.service postfix.service

[Service]
User=openemm
Group=openemm
Type=oneshot
RemainAfterExit=true
ExecStart=/home/openemm/bin/openemm.sh start
ExecStop=/home/openemm/bin/openemm.sh stop
TimeoutSec=300
StandardOutput=journal+console
[Install]
WantedBy=multi-user.target

#systemctl enable openemm

#systemctl daemon-reload

hostmaster
Posts: 3
Joined: Thu Sep 10, 2020 10:03 am

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by hostmaster » Mon Oct 05, 2020 12:17 pm

maschoff wrote:
Wed Sep 02, 2020 8:50 am
Please tell us the errors in the install guide so that we can improve it. Without knowing the errors I can not assess the situation.
Dear maschoff,
any chance You could have a look into this issue?

hostmaster
Posts: 3
Joined: Thu Sep 10, 2020 10:03 am

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by hostmaster » Wed Oct 14, 2020 5:34 pm

Dear maschoff,
could You please have a look at the issue. In the case You need any data, please ask!
hostmaster wrote:
Thu Sep 10, 2020 10:22 am
maschoff wrote:
Wed Sep 02, 2020 8:50 am
Please tell us the errors in the install guide so that we can improve it. Without knowing the errors I can not assess the situation.
Dear mod or maintainer,
I post on behalf of user wehsemann, as i am the one who installs openemm 20.04 Centos 8

Logfile /home/openemm/tomcat9/logs/localhost.2020-08-25.log
https://pastebin.com/yrvRJd7P

wehsemann
Posts: 5
Joined: Tue Aug 25, 2020 7:50 am

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by wehsemann » Fri Oct 23, 2020 7:47 am

Dear @maschoff,
any news about this?

Best regards
Wendy

wehsemann
Posts: 5
Joined: Tue Aug 25, 2020 7:50 am

Re: Error HTML Tag (div, a, etc) not allowed in mailing wizzard

Post by wehsemann » Fri Oct 30, 2020 8:49 am

maschoff wrote:
Wed Sep 02, 2020 8:50 am
Please tell us the errors in the install guide so that we can improve it. Without knowing the errors I can not assess the situation.
Dear maschoff,
we send more information. Can you please check it.
Thank you Wendy

Post Reply