Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?

Use this forum to suggest new features, language support, documentation, etc. for OpenEMM's roadmap

Moderator: moderator

JuergenB
Posts: 72
Joined: Thu Dec 05, 2019 9:03 pm

Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?

Post by JuergenB » Mon Jun 15, 2020 12:19 pm

Hi,

in the new guide you strongly recommend to install DBMS and OpenEMM runtime.

But in 3.4 MariaDB and mysqlclient wil be installed?

How will this work if Pyhton is not installed yet?

If you use OpenEMM 20.04, install the required MariaDB API and the python driver with
# yum install mariadb-devel
# python3 -m pip install mysqlclient

And how will OpenEMMInstaller.sh work withouth Python 3.8?

maschoff
Site Admin
Posts: 2512
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?

Post by maschoff » Mon Jun 15, 2020 1:47 pm

OpenEMMInstaller needs Python 3, but not 3.8 to run.
OpenEMM Maintainer

JuergenB
Posts: 72
Joined: Thu Dec 05, 2019 9:03 pm

Re: Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?

Post by JuergenB » Mon Jun 15, 2020 1:50 pm

This is the software stack required by OpenEMM 19.04 and later:
• 64-bit version of RedHat 7/CentOS 7 or RedHat 8/CentOS 8 or SLES 15
• Java Open JDK 8 (any OpenEMM) or 11 (OpenEMM 20.04)
• Apache Tomcat 9
• Python 2.7 (OpenEMM 19.x) or Python 3.8 (OpenEMM 20.04)
• DBMS: MariaDB 10.1, 10.2 or 10.3; MySQL 5.6 or 5.7
• MTA: Postfix 2.6 or later; Sendmail 8.10 or later
• for image and PDF creation: command line tool wkhtmltox 0.12.2.1 or later
• for HTTPS support: Apache Tomcat Native Library

Pyhton3 is no requirement for OpenEMM ?

And later in 12 Deployment, the guide says

Do not install the Python package provided by your operating system!

I am wondering why the guide installs Python 3.8 and laters links into a Python3 path.

many website describe the Python 3.8 compilation and warn not use make install, instead we should use make altinstall

make altinstall is used to prevent replacing the default python binary file /usr/bin/python and create separate binary file.


So the installer wil not work with Python 3.8?

maschoff
Site Admin
Posts: 2512
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?

Post by maschoff » Mon Jun 15, 2020 1:56 pm

You have to distinguish between the installer and OpenEMM. If you use the latest installer with OpenEMM 19.10, you need Python 3 for the installer, but not Python 3.8 for OpenEMM 19.10.
OpenEMM Maintainer

JuergenB
Posts: 72
Joined: Thu Dec 05, 2019 9:03 pm

Re: Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?

Post by JuergenB » Mon Jun 15, 2020 2:01 pm

Thanks,

i use the installer openemm-runtime-20.04.000.043.tar with CentOS 8, minimal install.
and i don´t install python3 i compile python 3.8.

Can you fork the documentation to 19.10 with CentOS 7 and 20.04 with CentOS 8?

Post Reply