agnForm tags not converted

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

iwolf
Posts: 3
Joined: Mon Feb 22, 2021 9:51 am

agnForm tags not converted

Post by iwolf » Fri Mar 05, 2021 1:48 pm

I am working to get OpenEmm running the first time with Double-Opt-In. I have a small issue when it comes to the confirmation link in that is sent by e-mail. The link to the form looks like - and does not work:

[agnFORM name="Bestaetigunsformular"/] becomes:
https://mydomain/form.do?agnCI=1&agnFN= ... D=##AGNUID##

As you can see the OpenEmm tags are not converted to the users secure id.

When I add the link directly into the e-mail content it looks like this and works:

https://mydomain/r.html?uid=D.A.d.R.GX. ... tyFdfe1Lbg

Did I miss something.

Any help would be appreciated.

maschoff
Site Admin
Posts: 2493
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: agnForm tags not converted

Post by maschoff » Sat Mar 06, 2021 10:19 am

Maybe it is because you misspelled the form name either in EMM or in the link?
OpenEMM Maintainer

iwolf
Posts: 3
Joined: Mon Feb 22, 2021 9:51 am

Re: agnForm tags not converted

Post by iwolf » Wed Mar 10, 2021 8:21 am

The name of the form is:
"Bestaetigungsformular" and the link shown in the form content tab shows like:
https://domain/form.do?agnCI=1&agnFN=Be ... D=##AGNUID##

The converted link from "[agnFORM name="Bestaetigungsformular"/]" shown in the mailing:
https://domain/form.action?agnCI=1&agnF ... D=##AGNUID##

The only difference ist the form.do vs form.action

If I put
https://domain/form.action?agnCI=1&agnF ... D=##AGNUID##
directly into the mailing, it is converted correctly

The link to the form seem to be fine.

Post Reply