Only 4 Options in the Menu?

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

Kittlitz
Posts: 24
Joined: Sun Jan 31, 2021 11:34 am

Only 4 Options in the Menu?

Post by Kittlitz » Mon Feb 01, 2021 12:58 pm

Reading the Manual says there should be much more options than this four:

- Medienpool
- Layout Builder
- Push Nachrichten
- Verwaltung

The first three also simply say "Are you missing something?" - there is no functionality.
Verwaltung allowed to change the real name of the User and to see the log of last actions (Logging, changed Username etc.)

Any hint what's wrong?

Image

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Only 4 Options in the Menu?

Post by maschoff » Mon Feb 01, 2021 4:59 pm

Looks like the installation of the OpenEMM database is not complete because your user is missing a lot of permissions. Do you log in as user "emm-master"?
OpenEMM Maintainer

Kittlitz
Posts: 24
Joined: Sun Jan 31, 2021 11:34 am

Re: Only 4 Options in the Menu?

Post by Kittlitz » Mon Feb 01, 2021 5:23 pm

Yes, I'm using the "emm-master" account and got stuck here.
Any suggestions how to repair this?

== UPDATE ==

I've started ./OpenEMMInstaller.sh again, and chose
-Menu 3) Database Maintenance
and then
- 4) Create new database (drop existing data)

After entering the mariaDB-Root-Password twice the setup started, but then failed here:

[...]
Executing /home/openemm/webapps/emm/WEB-INF/sql/mysql/emm-mysql-update-20.10.120-basic.sql
ERROR 1091 (42000) at line 45: Can't DROP FOREIGN KEY `lock$cust_ban_tbl`; check that it exists
Error while executing /home/openemm/webapps/emm/WEB-INF/sql/mysql/emm-mysql-update-20.10.120-basic.sql
SQL DB updates caused an error. Press any key to continue.

I assume that this might be the reason.

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Only 4 Options in the Menu?

Post by maschoff » Tue Feb 02, 2021 1:13 pm

Please re-try with latest release 20.10.000.128.
OpenEMM Maintainer

Kittlitz
Posts: 24
Joined: Sun Jan 31, 2021 11:34 am

Re: Only 4 Options in the Menu?

Post by Kittlitz » Tue Feb 02, 2021 3:11 pm

I would like to re-try, but don't know how to get the .128-Version.

I've tried:
a)
./OpenEMMInstaller.sh -> Option 5. Install or update package from AGNITAS Website -> No newer Version found:

Package contains application type 'Runtime' of version '20.10.070'.
Your current version is '20.10.070'.
This is the same version.
Install anyway? (N/y, Blank => Cancel):

b)
Just to be on the safe side -> I started .OMT.sh -> same result (as expected)

c)
Downloaded the Binary again (openemm-runtime_20.10.070.tar.gz) - but it's the same filesize and date.

Please give me a hint, where to find the .SQL-Files you're refering to.

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Only 4 Options in the Menu?

Post by maschoff » Tue Feb 02, 2021 3:36 pm

You should not update the runtime package but the OpenEMM package.
OpenEMM Maintainer

Kittlitz
Posts: 24
Joined: Sun Jan 31, 2021 11:34 am

Re: Only 4 Options in the Menu?

Post by Kittlitz » Tue Feb 02, 2021 5:42 pm

Sorry, I'm lost right now.

Even on the git-Repository it's version 20.10.000.126

https://github.com/agnitas-org/openemm

Could you provide a link please?

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Only 4 Options in the Menu?

Post by maschoff » Tue Feb 02, 2021 6:25 pm

Say "no" to the runtime update and wait for the next step.
OpenEMM Maintainer

Kittlitz
Posts: 24
Joined: Sun Jan 31, 2021 11:34 am

Re: Only 4 Options in the Menu?

Post by Kittlitz » Tue Feb 02, 2021 7:03 pm

Ok, I started the Script: bin/OpenEMMInstaller.sh

Chose Option 5
Current menu: Install or update package from AGNITAS Website

OpenEMM Update via AGNITAS Website
Download and install latest packages (only openemm-package needs root permissions for OMT)? (N/y, Blank => Cancel):
> y
Starting OpenEMM Update ...

Package contains application type 'Runtime' of version '20.10.070'.
Your current version is '20.10.070'.
This is the same version.
Install anyway? (N/y, Blank => Cancel):
> N

Package contains application type 'Apache Tomcat' of version '9.0.33'.
Your current version is '9.0.33'.
This is the same version.
Install anyway? (N/y, Blank => Cancel):
> n

Package contains application type 'Apache Tomcat Native' of version '1.2.23'.
Your current version is '1.2.23'.
This is the same version.
Install anyway? (N/y, Blank => Cancel):
> n

---> The Script jumps back to the main-menu, showing this Error-Message:
Error while deploying update package /home/openemm/release/log/update_2021-02-02_18-39-30.log)

The Log contains:

Code: Select all

Update started at: 2021-02-02_18:39:30
Update package url: https://share.agnitas.de/index.php/s/bpiTmdvOalXSEyz/download
Update package file: openemm-runtime-20.10.070.tar.gz
Declined installation of version '20.10.070' for application 'runtime'
Update package url: https://share.agnitas.de/index.php/s/Tz6jMmBs8ZzQMfE/download
Update package file: apache-tomcat-9.0.33.tar.gz
Declined installation of version '9.0.33' for application 'tomcat'
Update package url: https://share.agnitas.de/index.php/s/G95WOP3wjqrnqJr/download
Update package file: apache-tomcat-native-1.2.23-CentOS8.tar.gz
Declined installation of version '1.2.23' for application 'tomcat-native'
Update package url: https://share.agnitas.de/index.php/s/Py6y7AwjaoyZzjL/download
Update package file: openemm-code-20.10.000.128.tar.gz
Error while deploying update package (Log: /home/openemm/release/log/update_2021-02-02_18-39-30.log)
Update ended at: 2021-02-02_18:40:13
So I downloaded the .128 myself via

Code: Select all

wget https://share.agnitas.de/index.php/s/Py6y7AwjaoyZzjL/download
mv download openemm-code-20.10.000.128.tar.g
And then deployed the three containing parts myself.

In the File /home/openemm/tomcat9/bin/OMT.py I've added a new line after 6420

Code: Select all

databaseMenu.addSubMenu(Menu("Create new database (drop existing data)", lambda: Utilities.checkDbStructureExists() and Environment.dbClientPath != None).setAction(clearDatabaseMenuAction))
databaseMenu.addSubMenu(Menu("Create new database", lambda: Environment.dbClientPath != None).setAction(clearDatabaseMenuAction))
Because the Option for creating a new Database was not shown in the Menu after I've droped the old DB-Schema due to the lambda-expression in Line 6420.

Starting the Script: bin/OpenEMMInstaller.sh again allowes me now to Drop an Recreate the Database.

Current menu: Create new database (drop existing data)

Are you sure to drop all current data from database? ('DROP' => drop data, Blank => Back):
> DROP
Please enter database root user password:
> [...]
Dropping database data (openemm) ...
Please enter database root user password:
> [...]
Database data was dropped
Creating new database structure
DB update started

DB already contains version 20.01.368
[...]

I works and goes back to the Mainmenu where it's stated:

Database data was dropped
Database data was dropped and recreated


Then I went to Menu 4 - Security, got myself a new Password for user 'emm-master'.

After this it was necessary to restart openEMM (Option 10), as Tomcat needs to reload et voilá:

Image

Thank you for your hint and hopefully my description of Issues helps to improve the open Source Version a bit.

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Only 4 Options in the Menu?

Post by maschoff » Tue Feb 02, 2021 7:21 pm

Did you notice hint "only openemm-package needs root permissions for OMT"? Did you start OMT as user root?
OpenEMM Maintainer

Kittlitz
Posts: 24
Joined: Sun Jan 31, 2021 11:34 am

Re: Only 4 Options in the Menu?

Post by Kittlitz » Tue Feb 02, 2021 7:48 pm

Yes, I've started it as root.

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Only 4 Options in the Menu?

Post by maschoff » Wed Feb 03, 2021 10:03 am

OK, in the new runtime package release 20.10.075 we integrated the option to create a new OpenEMM database in any case.
OpenEMM Maintainer

Post Reply