system fields lastclick_date and lastopen_date are empty

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

e.mail.guru
Posts: 7
Joined: Tue Sep 01, 2020 8:19 am

system fields lastclick_date and lastopen_date are empty

Post by e.mail.guru » Thu Jan 28, 2021 8:59 pm

With several tests and openings (Outlook data downloaded) the fields lastclick_date and lastopen_date remain empty. Why does openemm not write any information in these fields? I am using version 20.10.000.107. Thanks for the answer.

mdoerschmidt
Posts: 24
Joined: Fri Jan 04, 2013 8:55 am

Re: system fields lastclick_date and lastopen_date are empty

Post by mdoerschmidt » Fri Jan 29, 2021 12:00 pm

Writing the last open and last click date is disabled by default.

To enable it, execute this SQL statement on your database:
INSERT INTO config_tbl (class, name, value) VALUES ('measure', 'writecustomeropenorclickfield', 'true');

After inseting this configuration key, you either have to wait 5 minutes or restart your OpenEMM.

e.mail.guru
Posts: 7
Joined: Tue Sep 01, 2020 8:19 am

Re: system fields lastclick_date and lastopen_date are empty

Post by e.mail.guru » Fri Jan 29, 2021 7:14 pm

Thanks for the answer. It works. Nearly.

If you click after opening, the value in the lastopen_date field is overwritten. The values ​​are then identical (lastopen_date = lastclick_date).

A mistake or intent?

maschoff
Site Admin
Posts: 2478
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: system fields lastclick_date and lastopen_date are empty

Post by maschoff » Fri Jan 29, 2021 7:28 pm

You may activate the writing of these fields with

Code: Select all

INSERT INTO company_info_tbl (company_id, cname, cvalue) VALUES (0, 'measure.writecustomeropenorclickfield', 'true')
But be aware that this costs some database performance.
OpenEMM Maintainer

Post Reply