changing colums in default recipient view

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

mokarram
Posts: 32
Joined: Thu Jan 19, 2012 11:27 pm

changing colums in default recipient view

Post by mokarram » Wed Mar 07, 2012 6:14 pm

I was wondering if it is possioble to display custom feilds on the default reciepient layout by changin the following code:

Location: /home/openenn/webapps/openemm/recipient/recipient-list.jsp

Code: Select all

<display:table class="list_table"
				pagesize="${recipientForm.numberofRows}" id="recipient"
				name="recipientList" sort="external" excludedParams="*"
				requestURI="/recipient.do?action=${ACTION_LIST}&__fromdisplaytag=true"
				partialList="true" size="${recipientList.fullListSize}">
				<display:column class="name" headerClass="head_name"
					titleKey="recipient.Salutation">
					<bean:message key="recipient.gender.${recipient.gender}.short" />
				</display:column>
				<display:column class="name" headerClass="head_name"
					property="firstname" titleKey="recipient.Firstname" sortable="true" />
				<display:column class="name" headerClass="head_name"
					property="lastname" titleKey="recipient.Lastname" sortable="true" />
				<display:column class="name" headerClass="head_name"
					property="email" titleKey="mailing.E-Mail" sortable="true"
					paramId="recipientID" paramProperty="customerID"
					url="/recipient.do?action=${ACTION_VIEW}" />
What I did was define a new alphanumeric field, then modified:

Code: Select all

<display:column class="name" headerClass="head_name"
					property=NEWFIELD" titleKey="recipient.NEWFIELD" sortable="true" />
This returned an error because property=NEWFIELD is not defined. Would any one know where I would define the new property for the NEWFIELD in the above example? Should I be asking Santa ? :D

unhuman
Posts: 46
Joined: Mon Jan 23, 2012 10:29 pm

Re: changing colums in default recipient view

Post by unhuman » Wed Mar 07, 2012 9:15 pm

I'm betting you need to add, at a minimum, that column to your database.

You should attempt to attach a debugger (Eclipse) to the running Tomcat to see what's going on under the covers. There's always more to do that just play with the JSPs. :)

Post Reply