2020.04 question on TextModules

Use this forum for questions regarding adoption and functionality of OpenEMM

Moderator: moderator

horstL
Posts: 7
Joined: Sat Oct 24, 2015 4:32 pm

2020.04 question on TextModules

Post by horstL » Thu Jun 25, 2020 3:25 pm

hi all

question on Templates/CURRENT_TEMPLATE/Content/TextModules: this has changed from 2015 to 2020.04 that only 2 are available and not able to add more ?
I have imported from 2015 with multiple TextModule lines / they are shown but I can't add a new line in the new version ...

new version has only: Text / HTML-Version

planned (and moved to layout package) ? or bug ?

perhaps somebody can enlighten me...

br horst

maschoff
Site Admin
Posts: 2312
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: 2020.04 question on TextModules

Post by maschoff » Sat Jun 27, 2020 1:49 pm

This functionally should not have changed going from OpenEMM 2015 to 2019. Please explain the steps that do not work for you so that we can try to reproduce.
OpenEMM Maintainer

horstL
Posts: 7
Joined: Sat Oct 24, 2015 4:32 pm

Re: 2020.04 question on TextModules

Post by horstL » Mon Jun 29, 2020 9:42 am

hi maschoff,

current System: 2020.04.143 Frontend / from ovf

I ported all Data from the old system to the current one (via DWH I will put my kettle scripts afterwards online on Dev forum), and first I thought I have made something wrong...

but when I create a new Template via
Mailings/ Templates / New Template

entered Data:
Template Name
Email infos:
subject / format text, html and offline html / sender email / sender full name / reply email
general settings:
mailing list / mailing type normal
rest default

Save

/ now go to content Tab

TextModules Table

Code: Select all

Text module 		Target group 	Content
HTML-Version 		
Text 	All recipients 	The content of this e-mail is only .
but no chance to Add a new Block / in old version there was after every line a button to add a new line / Block

if I click on one it opens
example HTML Version
left side recipients / right side HTML - Wysiwyg

in the transferred I have these lines which means I must be possible (but: I have an error because of dyn Tags preview is empty message...)

perhaps you can help me

br horst

maschoff
Site Admin
Posts: 2312
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: 2020.04 question on TextModules

Post by maschoff » Tue Jun 30, 2020 1:00 pm

If you want to add a new text module to a mailing, you have to define it with the agnDYN tag first.

The only option to add an element is to add a new version of content for a certain target group:
menu Mailing -> select Mailing -> tab Content -> select Text module -> select button "+" in the left column

While the GUI to edit content of text modules has changed to improve the usability, functionality has not been limited.
OpenEMM Maintainer

horstL
Posts: 7
Joined: Sat Oct 24, 2015 4:32 pm

Re: 2020.04 question on TextModules

Post by horstL » Mon Jul 13, 2020 4:56 pm

hi

thank you for the explanation now it works, my problem was coming from something different (import data from 2015 Version .... and one flag missing)
I will put the complete port 2015->2020 info in then Installation and upgrade index. perhaps somebody else would need it..

bg horst

maschoff
Site Admin
Posts: 2312
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: 2020.04 question on TextModules

Post by maschoff » Mon Jul 13, 2020 7:18 pm

Glad, it worked out for you.
OpenEMM Maintainer

Post Reply