[Solved] Unable to install

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

econix
Posts: 2
Joined: Fri Oct 29, 2021 10:39 am

[Solved] Unable to install

Post by econix » Fri Oct 29, 2021 2:30 pm

Hello,

i have set up an CentOS Server as described in the documentation. Got then OpenEMM Runtime tar and unzip it into the home-folder of the user openemm. Started the OMT.sh and did the configuration, but now i'm stuck.
When i choose 5 to install then it updates something but no database is filled with data and openemm cannot startet.
What i'm doing wrong?

Cheers
Flo

Edit: my first attemp with 21.04.099(?) had no problems with the database vendor mariadb, this message occours first after update!

Code: Select all

=============================================
= OpenEMM Maintenance Tool (OMT) v21.10.028 =
=============================================
Root mode: On
Hostname: olcs-34.econix.int
OpenEMM Runtime Version: 21.10.028
OpenEMM Version: Unknown
System-Url: Unknown

Current menu: Show OpenEMM status

OpenEMM status:
Operating System (OS): CentOS 8
Python version: 3.8.6 (default, Jan 29 2021, 17:38:16)  [GCC 8.4.1 20200928 (Red Hat 8.4.1-1)]
The database vendor mariadb is not supported by this python installation
Postfix Version: 3.5.8
Database client version: /usr/bin/mysql  Ver 15.1 Distrib 10.3.28-MariaDB, for Linux (x86_64) using readline 5.1
Database Connection: OK
System-Time: 2021-10-29 09:22:23
System-Time-DB: 2021-10-29 09:22:23
Database version: MariaDB 10.3.28-MariaDB
OpenEMM database structure does NOT exist
Java version: 1.8.0_302 (Oracle)
Tomcat version: 10.0.10.0
Tomcat-Native version: 1.2.30
Wkhtml version: wkhtmltopdf 0.12.6 (with patched qt)
OpenEMM Application is NOT running
Last edited by econix on Wed Nov 03, 2021 11:02 am, edited 1 time in total.

maschoff
Site Admin
Posts: 2512
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Unable to install

Post by maschoff » Sun Oct 31, 2021 7:51 am

If you install the OpenEMM code package, the database structure will be created automatically. Make sure to start OMT as user root, otherwise you can not install the OpenEMM code.
OpenEMM Maintainer

econix
Posts: 2
Joined: Fri Oct 29, 2021 10:39 am

[SOLVED] Re: Unable to install

Post by econix » Wed Nov 03, 2021 11:02 am

Thanks for the answer, now the installation is fine. How can i close this topic?

maschoff
Site Admin
Posts: 2512
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: [Solved] Unable to install

Post by maschoff » Wed Nov 03, 2021 11:04 am

Your subject prefix [Solved] is fine.
OpenEMM Maintainer

Post Reply