Update Error OpenEMM ->

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

Posts: 28
Joined: Thu Feb 25, 2016 11:19 am

Update Error OpenEMM ->

Post by MSelke » Thu Mar 25, 2021 2:28 pm

I have installed openEMM from scratch with a new DB. It is running without any errors so far.
Now i run the latest Update with the Maintenance Tool and get the following error.

Code: Select all

ERROR 1064 (42000) at line 14: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IF EXISTS lock$cust_ban_tbl;
  ALTER TABLE prevent_table_drop DROP KEY IF EXISTS' at line 9
Error while executing /home/openemm/webapps/emm/WEB-INF/sql/mysql/emm-mysql-update-20.10.121-basic.sql
I use the following Mysql 5.7.33

And i found the one possible explanation. I looked in the tables and the update script and found that one table name didnt match.

Name in database: cust1_ban_tbl
Name in script: lock$cust_ban_tbl

Here "viewtopic.php?f=2&t=6614&start=15#p17144" you provide an updated script but i didnt work either

I tried the script statements from line 9.

Line 9 and 10 both didnt work because there is no cust_ban_tbl, only cust1_ban_tbl, Line 12 runs fine and 13 tries also to alter cust_ban_tbl, which don't exists, because, why?

What are the changes in the script? Or do i have to rename the table?

Posts: 21
Joined: Fri Jun 19, 2015 12:43 pm

Re: Update Error OpenEMM ->

Post by aso » Fri Mar 26, 2021 10:36 am

You are completely right.
There is no "cust_ban_tbl" in OpenEMM.
We fixed it in Version, which is available right now.

The changes are made to address the problem of MySQL and MariaDB in general, that there is no difference in varchars with Umlaut and special characters.
"test-ß@example.com" is handled als equal to "test-ss@example.com" by db in standard collation.
So we needed to adapt the collation of the ban tables.

Posts: 28
Joined: Thu Feb 25, 2016 11:19 am

Re: Update Error OpenEMM ->

Post by MSelke » Fri Mar 26, 2021 3:10 pm

The Updated script worked, but the next script throw another error

Code: Select all

Executing /home/openemm/webapps/emm/WEB-INF/sql/mysql/emm-mysql-update-20.10.522-basic.sql
ERROR 1146 (42S02) at line 11: Table 'openemm.feature_tbl' doesn't exist
Error while executing /home/openemm/webapps/emm/WEB-INF/sql/mysql/emm-mysql-update-20.10.522-basic.sql
I looked into mysql and didnt find a feature_tbl.

Did i miss something?

Post Reply