Statistics don't work

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

andrearossi
Posts: 20
Joined: Mon Dec 21, 2020 11:30 am

Statistics don't work

Post by andrearossi » Tue Jan 19, 2021 3:26 pm

Hello, after a reinstallation from scratch now I have all the services up and running.
The issue now is that some components of OpenEMM still don't work.
If I want to check the Statistics or Heatmap panels via the Frontend, I always get Connection Refused. Basically the same problem of this old (unanswered) thread -> viewtopic.php?t=1640

What could be the problem? Missing a config somewhere?
Thanks

maschoff
Site Admin
Posts: 2512
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Statistics don't work

Post by maschoff » Tue Jan 19, 2021 8:26 pm

Have you configured the basic parameters as described in chapter 5.4 of the Install&Admin Guide?
OpenEMM Maintainer

andrearossi
Posts: 20
Joined: Mon Dec 21, 2020 11:30 am

Re: Statistics don't work

Post by andrearossi » Wed Jan 20, 2021 10:34 am

Do you mean rdir_domain and mailloop_domain? Or something specific among the ones in the basic configuration section?
BTW at the moment I don't have a proper domain like openemm@example.com, I put my internal IP address like 10.x.x.x and the other parameters were set based on that address.

maschoff
Site Admin
Posts: 2512
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Statistics don't work

Post by maschoff » Wed Jan 20, 2021 11:01 am

So, when OMT asked you to enter the full URL of your server including protocol, what did you enter?
OpenEMM Maintainer

andrearossi
Posts: 20
Joined: Mon Dec 21, 2020 11:30 am

Re: Statistics don't work

Post by andrearossi » Wed Jan 20, 2021 12:06 pm

Ok maybe I fixed it: checking the web calls with the browser element inspector, I saw I missed somewhere to put the 8080 port in a certain setting.
Then I added a redirect 80 to 8080 in my iptables and now I don't have that error anymore.

About you question, I entered

Code: Select all

http://10.x.x.x

Post Reply