Unable to change configuration variables

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

fernando
Posts: 11
Joined: Thu Jul 30, 2020 3:23 pm

Unable to change configuration variables

Post by fernando » Fri Sep 18, 2020 7:52 pm

Dear support, I couldn't go any further than 5.4 Configuration.

OpenEMMInstaller dos not allow me to change system.url and birt.drilldownurl, as you can see below, they even exists in the menu:

Code: Select all

================================
= OpenEMM Installer v20.04.003 =
================================
Host: mm3.v2v.net
License: OpenEMM (ID: 0)
Runtime Version: 20.04.000.043
Manual Version: 20.04.011
OpenEMM Version: 20.04.000.188
System-Url: Unknown
OpenEMMBackend Version: 20.04.000.190

Current menu: Change configuration of installation in DB

OpenEMM configuration in DB

 clean.mastercompany = true
 mailloop.actionbased_autoresponder_ui = enabled
 system.<hostname>[to be defined].IsActive = 1
 system.licence = 0
 system.mm3.v2v.net.IsActive = 1
 system.RdirLandingpage = http://www.openemm.org
 system.support_emergency_url = http://www.openemm.org/systemstoerung

Please choose entry name to change (Blank => Back):
 >
 
I've even try these parameters, but the script returns "Invalid entry key name: system.url"

Am I missing something?
Best regards!

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Unable to change configuration variables

Post by maschoff » Fri Sep 18, 2020 8:39 pm

Your list of properties does not show parameter system.url at all, or is your post incomplete?

Which value does file emm.properties hold for property system.url?
OpenEMM Maintainer

fernando
Posts: 11
Joined: Thu Jul 30, 2020 3:23 pm

Re: Unable to change configuration variables

Post by fernando » Fri Sep 18, 2020 9:38 pm

Hello maschoff, the list does not show system.url or birt.drilldownurl. My post is not incompleted.

I've tried rebuild OpenEMM database, but it turns out with the same parameters as showed here.

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Unable to change configuration variables

Post by maschoff » Sat Sep 19, 2020 6:58 am

Please answer my 2nd question too.
OpenEMM Maintainer

fernando
Posts: 11
Joined: Thu Jul 30, 2020 3:23 pm

Re: Unable to change configuration variables

Post by fernando » Tue Sep 22, 2020 4:04 pm

Hello maschoff, sorry for the delay.

The value for system.url and birt.drilldownurl was something like [to-be-defined] on emm.properties

I've changed the values to my domain, but it still doesn't work.

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Unable to change configuration variables

Post by maschoff » Tue Sep 22, 2020 4:22 pm

Did you do the change before updating to 20.04 after it?
OpenEMM Maintainer

fernando
Posts: 11
Joined: Thu Jul 30, 2020 3:23 pm

Re: Unable to change configuration variables

Post by fernando » Wed Sep 23, 2020 1:30 pm

This is a new installation. I've changed after the installation.
best regards!

fernando
Posts: 11
Joined: Thu Jul 30, 2020 3:23 pm

Re: Unable to change configuration variables

Post by fernando » Wed Sep 23, 2020 1:55 pm

Below is a selection form config_tbl table:

Code: Select all

mysql> select * from config_tbl;
+----------+------------------------------------+---------------------------------------+----------+
| class    | name                               | value                                 | hostname |
+----------+------------------------------------+---------------------------------------+----------+
| system   | licence                            | 0                                     | NULL     |
| system   | support_emergency_url              | http://www.openemm.org/systemstoerung | NULL     |
| system   | RdirLandingpage                    | http://www.openemm.org                | NULL     |
| system   | <hostname>[to be defined].IsActive | 1                                     | NULL     |
| mailloop | actionbased_autoresponder_ui       | enabled                               | NULL     |
| clean    | mastercompany                      | true                                  | NULL     |
| system   | mm3.v2v.net.IsActive               | 1                                     | NULL     |
| system   | wkhtmltopdf                        | /usr/local/bin/wkhtmltopdf            | NULL     |
| system   | wkhtmltoimage                      | /usr/local/bin/wkhtmltoimage          | NULL     |
+----------+------------------------------------+---------------------------------------+----------+
9 rows in set (0.00 sec)
and

aso
Posts: 21
Joined: Fri Jun 19, 2015 12:43 pm

Re: Unable to change configuration variables

Post by aso » Fri Sep 25, 2020 10:00 am

In LTS 20.04 all relevant configuration properties are migrated from emm.properties in db config_tbl for later use in LTS 20.10.
This happens on EMM startup. SO if the values are included in emm.peroperties an you (re-)start up your EMM the values should pop up in config_tbl.

fernando
Posts: 11
Joined: Thu Jul 30, 2020 3:23 pm

Re: Unable to change configuration variables

Post by fernando » Tue Sep 29, 2020 11:18 pm

Dear support,
today I've updated the installer to v20.10.018. My installation is working now.
Thank you for your help an patience.
Best gegards!
Fernando

maschoff
Site Admin
Posts: 2511
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Unable to change configuration variables

Post by maschoff » Fri Nov 26, 2021 8:12 pm

I can not see the message.
OpenEMM Maintainer

Post Reply