OVA File does not work in ESXi

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

mykp
Posts: 21
Joined: Fri Aug 28, 2020 6:05 pm
Contact:

OVA File does not work in ESXi

Post by mykp » Fri Aug 28, 2020 6:11 pm

Hi everybody,
I wanted to give OpenEMM a test, but I cannot register the ova-file within ESXi (ESXi-Version: 6.7.0).
After I tell the system to use thin (or thick) provisioning and to start up the machine automatically, I get this error:

Line 68: unsupported element 'StorageItem'
(Original text in German: Zeile 68: Nicht unterstütztes Element 'StorageItem')

and below it says something like

Error when creating the import specification from OVF-file
(Original text in German: Beim Erstellen der Importspezifikation aus der OVF-Datei ist ein Fehler aufgetreten.)

Has anybody an idea what to do about this?
Thanks for any help in advance!
Klaus

rodig03
Posts: 44
Joined: Thu Sep 18, 2014 1:27 pm

Re: OVA File does not work in ESXi

Post by rodig03 » Sat Aug 29, 2020 4:49 pm

Hi,
did you check these limitations?
https://docs.vmware.com/en/VMware-vSphe ... 51C1C.html

And maybe try to use the English tools - you could have an issue with the languages within ESXi.

mykp
Posts: 21
Joined: Fri Aug 28, 2020 6:05 pm
Contact:

Re: OVA File does not work in ESXi

Post by mykp » Fri Sep 04, 2020 2:16 pm

Hello Rodig03,
thanks for the advice. I did un-tar the files, tried to upload it with Chrome,
but it's still not working. Also I ge the error message right at the start,
well before it's starting to upload anything at all.

Anybody another idea, what to look for?

Best regards
Klaus

mykp
Posts: 21
Joined: Fri Aug 28, 2020 6:05 pm
Contact:

Re: OVA File does not work in ESXi

Post by mykp » Fri Sep 04, 2020 5:44 pm

By the way, I also tried the OVF Tool, but it gives me this:

>>
Error: OVF Package is not supported by target
- Line 68: Unsupported element 'StorageItem'
- Line 77: Unsupported element 'EthernetPortItem'
Completed with errors
<<

mfreundl
Posts: 24
Joined: Wed Aug 28, 2019 10:01 am

Re: OVA File does not work in ESXi

Post by mfreundl » Tue Sep 22, 2020 7:49 am

Hi, the problem seems to be that the OVA was created with the Open Virtualization Format 2.0.
It looks like VMware/ESXi does not support this format.

The OpenEMM OVA download will be updated with a supported format shortly.

mykp
Posts: 21
Joined: Fri Aug 28, 2020 6:05 pm
Contact:

Re: OVA File does not work in ESXi

Post by mykp » Wed Oct 14, 2020 11:07 am

Hello MFreundl,
great! I am very happy to hear this. We have meanwhile tried to install it via Virtuabox,
but have trouble getting the network up.
Do you happen to know (roughly) the time schedule for this to happen?

Best regards
Klaus

mykp
Posts: 21
Joined: Fri Aug 28, 2020 6:05 pm
Contact:

Re: OVA File does not work in ESXi

Post by mykp » Sat Oct 31, 2020 5:28 pm

Hi,
do you already know, when the updated version will be available?
We have put the project on hold, but of course it would be desirable
to know when it can continue ...

mfreundl
Posts: 24
Joined: Wed Aug 28, 2019 10:01 am

Re: OVA File does not work in ESXi

Post by mfreundl » Mon Nov 02, 2020 8:51 am

Hi,
sorry, I did not see your last reply.
The new OVA will be available with the OpenEMM 20.10 release.
This should be in the coming weeks, when OpenEMM 20.10 is out of beta.

There have to be some more changes in the OVA creation, thus no quick fix for 20.04.

mykp
Posts: 21
Joined: Fri Aug 28, 2020 6:05 pm
Contact:

Re: OVA File does not work in ESXi

Post by mykp » Tue Nov 17, 2020 11:30 am

Hello MFreundl,
have you got an updated schedule already for the release?

Best regards
Klaus

mfreundl
Posts: 24
Joined: Wed Aug 28, 2019 10:01 am

Re: OVA File does not work in ESXi

Post by mfreundl » Mon Nov 23, 2020 4:22 pm

Sorry, i have no updates yet.

Please keep in mind, that you can also install OpenEMM on a clean CentOS installation yourself.
Then there are no issues with importing the OVA, except some more steps to follow on your side.
See https://wiki.openemm.org/ for installation details.

mykp
Posts: 21
Joined: Fri Aug 28, 2020 6:05 pm
Contact:

Re: OVA File does not work in ESXi

Post by mykp » Wed Nov 25, 2020 7:35 am

Hello,
yes, we tried that *also*, but we run into several errors, the first one for example is this:

[root@myopenemm ~]# python3 -m pip install mysqlclient
WARNING: Running pip install with root privileges is generally not a good idea. Try `__main__.py install --user` instead.
Collecting mysqlclient
Downloading https://files.pythonhosted.org/packages ... 0.1.tar.gz (87kB)
100% |████████████████████████████████| 92kB 2.0MB/s
Installing collected packages: mysqlclient
Running setup.py install for mysqlclient ... error
Complete output from command /usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-9mk86ype/mysqlclient/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-j_yt27yz-record/install-record.txt --single-version-externally-managed --compile:
running install
running build
running build_py
creating build
creating build/lib.linux-x86_64-3.6
creating build/lib.linux-x86_64-3.6/MySQLdb
copying MySQLdb/__init__.py -> build/lib.linux-x86_64-3.6/MySQLdb
copying MySQLdb/_exceptions.py -> build/lib.linux-x86_64-3.6/MySQLdb
copying MySQLdb/connections.py -> build/lib.linux-x86_64-3.6/MySQLdb
copying MySQLdb/converters.py -> build/lib.linux-x86_64-3.6/MySQLdb
copying MySQLdb/cursors.py -> build/lib.linux-x86_64-3.6/MySQLdb
copying MySQLdb/release.py -> build/lib.linux-x86_64-3.6/MySQLdb
copying MySQLdb/times.py -> build/lib.linux-x86_64-3.6/MySQLdb
creating build/lib.linux-x86_64-3.6/MySQLdb/constants
copying MySQLdb/constants/__init__.py -> build/lib.linux-x86_64-3.6/MySQLdb/constants
copying MySQLdb/constants/CLIENT.py -> build/lib.linux-x86_64-3.6/MySQLdb/constants
copying MySQLdb/constants/CR.py -> build/lib.linux-x86_64-3.6/MySQLdb/constants
copying MySQLdb/constants/ER.py -> build/lib.linux-x86_64-3.6/MySQLdb/constants
copying MySQLdb/constants/FIELD_TYPE.py -> build/lib.linux-x86_64-3.6/MySQLdb/constants
copying MySQLdb/constants/FLAG.py -> build/lib.linux-x86_64-3.6/MySQLdb/constants
running build_ext
building 'MySQLdb._mysql' extension
creating build/temp.linux-x86_64-3.6
creating build/temp.linux-x86_64-3.6/MySQLdb
gcc -pthread -Wno-unused-result -Wsign-compare -DDYNAMIC_ANNOTATIONS_ENABLED=1 -DNDEBUG -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -D_GNU_SOURCE -fPIC -fwrapv -fPIC -Dversion_info=(2,0,1,'final',0) -D__version__=2.0.1 -I/usr/include/mysql -I/usr/include/mysql/mysql -I/usr/include/python3.6m -c MySQLdb/_mysql.c -o build/temp.linux-x86_64-3.6/MySQLdb/_mysql.o
MySQLdb/_mysql.c:46:10: schwerwiegender Fehler: Python.h: Datei oder Verzeichnis nicht gefunden
#include "Python.h"
^~~~~~~~~~
Kompilierung beendet.
error: command 'gcc' failed with exit status 1

----------------------------------------
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-9mk86ype/mysqlclient/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-j_yt27yz-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-9mk86ype/mysqlclient/






Would you be interested in doing an installation together with us
via Teamviewer or similar, against payment?

Best regards
Klaus

mfreundl
Posts: 24
Joined: Wed Aug 28, 2019 10:01 am

Re: OVA File does not work in ESXi

Post by mfreundl » Wed Nov 25, 2020 3:24 pm

Hello Klaus,
I have some news.
There is currently one bug left to fix before the new OVA is going to be created.
So it should not be too long to the new release.

Regarding your issue with installing mysqlclient:
It seems like you are using the wrong Python3 version.
OpenEMM requires Python 3.8 or later.
Installation instructions are in the Installation Guide at chapter 12.
After that you should be able to install the mysqlclient module.

For commercial support please take a look at our website
German
English

Best regards
Marcel

mfreundl
Posts: 24
Joined: Wed Aug 28, 2019 10:01 am

Re: OVA File does not work in ESXi

Post by mfreundl » Thu Nov 26, 2020 1:42 pm

The new OVA has been created and is available at https://www.agnitas.de/en/download/openemm-ova/.
Importing in ESXi works now (Tested with ESXi 7).

mykp
Posts: 21
Joined: Fri Aug 28, 2020 6:05 pm
Contact:

Re: OVA File does not work in ESXi

Post by mykp » Mon Nov 30, 2020 7:02 pm

ok, next step we can't solve:



Die MYSQL Datenbank wurde installiert und läuft.

Wenn man als root das Backend installieren möchte und hier die DB Configuration machen will:

=============================================
= OpenEMM Maintenance Tool (OMT) v20.10.059 =
=============================================
Root mode: On
Host: openemm.<Domäne>
Runtime Version: 20.10.063
Manual Version: Unknown
OpenEMM Version: Unknown
System-Url: Unknown
OpenEMMBackend Version: Unknown

Current menu: Change configuration of database connection

Database configuration for openemm:
dbms = mariadb
host = localhost
jdbc-connect = jdbc:mariadb://localhost/openemm?zeroDateTimeBehavior=convertToNull&useUnicode=true&characterEncoding=UTF-8
jdbc-driver = org.mariadb.jdbc.Driver
name = openemm
password = **************
user = openemm

Please choose entry name to change (Blank => Back):
>


Kommt nach dem Speichern „save“ folgende Meldung:

Changes saved.

Database and user do not exist and cannot be created. Please create database and user yourself.

Current configuration changes or updates need the OpenEMM system to be restarted.




What to do now, does anybody know?

maschoff
Site Admin
Posts: 2512
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: OVA File does not work in ESXi

Post by maschoff » Tue Dec 01, 2020 10:28 am

Please do not post content in any other language than English.

The error messag says "Please create database and user yourself." So, you should create an empty database with name "openemm" and you should create a database user who is able to access this database.
OpenEMM Maintainer

Post Reply