multiple config entries with same key after upgrade to 20.04

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

rodig03
Posts: 44
Joined: Thu Sep 18, 2014 1:27 pm

multiple config entries with same key after upgrade to 20.04

Post by rodig03 » Mon Aug 03, 2020 1:10 pm

Hi,
I am still hunting issues after the upgrade from 19.10 (and earlier versions before that) to 20.04.
In the Openemm Installer and change the config in the db I do get parameters that make sense to me but also

Code: Select all

mailout.ini.blocksize = 300  <---- 
mailout.ini.blocksize = 1000
...
mailout.ini.domain = nl.mydomain.tld
mailout.ini.domain = email.mydomain.tld  <---- 
...
system.nl.mydomain.tld.IsActive = 1
system.nl.mydomain.tld.IsActive = 1  <---- 
system.nl.mydomain.tld.IsActive = 1  <---- 
system.nl.mydomain.tld.IsActive = 1  <---- 
system.nl.mydomain.tld.IsActive = 1  <---- 
system.nl.mydomain.tld.IsActive = 1  <---- 
I assume that the lines with "<----" are not correct - but how to delete them?
Thanks and best regards,

Robert

rodig03
Posts: 44
Joined: Thu Sep 18, 2014 1:27 pm

Re: multiple config entries with same key after upgrade to 20.04

Post by rodig03 » Mon Aug 03, 2020 1:47 pm

Update:
I could remove the lines

Code: Select all

system.nl.mydomain.tld.IsActive = 1
by deleting all hosts in the job queue using OpenEMM Installer and adding it again once.

For the rest, I still have no idea yet.
Best regards,
Robert

maschoff
Site Admin
Posts: 2479
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: multiple config entries with same key after upgrade to 20.04

Post by maschoff » Tue Aug 04, 2020 10:17 am

Please explain exactly where you see this paramaters: in a config file (if so, please specify path and file name) or in the OpenEMM database (if so, please specify table name)?
OpenEMM Maintainer

rodig03
Posts: 44
Joined: Thu Sep 18, 2014 1:27 pm

Re: multiple config entries with same key after upgrade to 20.04

Post by rodig03 » Tue Aug 04, 2020 10:52 am

Hi,
I used OpenEMMInstaller.sh,

Current menu: Change configuration of installation in DB
OpenEMM configuration in DB

The entries listed there.
I did not manage any config file any more - any settings might ave been imported from the previous versions since 2013, 2015, 2015R2, 2019
Best regards,

Robert

aso
Posts: 21
Joined: Fri Jun 19, 2015 12:43 pm

Re: multiple config entries with same key after upgrade to 20.04

Post by aso » Tue Aug 04, 2020 1:14 pm

Hi,

Seems like there have been duplicates in some older OpenEMM version which were migrated.

When there are duplicates the first entry returned by database will be used.

To fix this just remove the unwanted configuration entries from database table "config_tbl".

Next OpenEMM version 20.10 will have an unique index to prevent these duplicate entries.

Post Reply