Setup.bat Doesn't allow for password entries

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

t2mg
Posts: 2
Joined: Wed Feb 13, 2008 5:39 am
Contact:

Setup.bat Doesn't allow for password entries

Post by t2mg » Sat Feb 23, 2008 5:30 am

Hi. I am attempting to install Win_OpenEMM-5.4.0 on Vista (Sorry, I'm a computer novice and don't know how to install an open source operating system)

All the files are downloaded and place in the C:\OpenEMM directory. WHen I run the setup.bat file, the script runs but nothing happens. I am not asked to put in a password at all.

I've downloaded and installed MySQL 5.0 Community Server, Python 2.5 for Windows and JDK version 6 as instructed.

Help!

gmsredraob
Posts: 1
Joined: Mon Jul 13, 2009 7:44 pm

Install issues on windows

Post by gmsredraob » Mon Jul 13, 2009 7:50 pm

I'm also having a similar issue with this. I followed the install instructions and can't get past step 2.1.1 when I run the setup.bat I get the following message.

Starting up .. home is c:\OpenEMM .. found codebase .. setup:
Setup database, please enter the super user password defined during MySQL instllation:
'mysqladmin' is not recognized as an internal or external command,
operable program or batchfile.
Failed to create database
[press return]


the spelling error above in installation was not by my mistake.

where can I specify the password or path to the mysqld files?

very annoying I'm half tempted to actually pay for a program.

Kiley Love
Posts: 3
Joined: Fri Apr 12, 2013 10:16 pm

Re: Setup.bat Doesn't allow for password entries

Post by Kiley Love » Fri Apr 12, 2013 10:22 pm

I had the same problem,

Here is what I did to fix it

run regedit
navigate to HKEY_USERS
navigate to user id (usually a string such as S-1-5-21-##########-##########-##########-####)
navigate to software
navigate to MySQL AB
navigate to MySQL Server 5.x
insert new string value (right click > new > string value)
name new string value "location"
modify new string value ( right click on "location" > select modify... )
enter path to MySQL Server 5.x\bin
mine was C:\Program Files\MySQL\MySQL Server 5.6\bin
click ok
go back to openemm and run setup.bat
worked for me.

this was pretty frustrating until I discovered that setup.bat doesn't use the windows environment path, instead it uses the registry setting, my installation of MySQL didn't put the location in the registry setting, so I had to manually enter it using the steps above. Hope this helps all those who run into the same problem on a windows install of OpenEMM...

Post Reply