Error while detecting Wkhtml version

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

openemmy
Posts: 12
Joined: Thu Jun 27, 2019 3:42 pm

Error while detecting Wkhtml version

Post by openemmy » Wed Jul 17, 2019 4:34 pm

I have made it further in attempting to install openemm-runtime-19.04.091 onto CentOS 7.
When I request status, I get the following two errors:

Error while detecting Wkhtml version
Error: <type 'exceptions.OSError'>

When I view config, the path to wk is correct.

WKHTMLTOPDF: /usr/local/bin/wkhtmltopdf
WKHTMLTOIMAGE: /usr/local/bin/wkhtmltoimage

How do I fix?
Complete status results below:

OpenEMM status:
OS version: CentOS Linux release 7.6.1810 (Core)
Python version: 2.7.5 (default, Jun 20 2019, 20:27:34) [GCC 4.8.5 20150623 (Red Hat 4.8.5-36)]
Postfix Version: 2.10.1
DB client version: /bin/mysql Ver 15.1 Distrib 10.2.22-MariaDB, for Linux (x86_64) using EditLine wrapper
Database Connection: OK
Database version: MariaDB 10.2.22-MariaDB
OpenEMM database structure exists (Version 19.07.007)
Currently running database threads ratio (Current: 1, Maximum: 6): 0.167
Database table emm_db_errorlog_tbl: OK
Jobqueue status: OK
No DKIM keys
Java version: 1.8.0_212 (OpenJDK)
Java JCE Unlimited-Key-Strength: OK
Tomcat version: 9.0.21.0
Error while detecting Wkhtml version
Error: <type 'exceptions.OSError'>
OpenEMM-Application is running (Tomcat ProcessID: 21374, started at: 08:58 5:43)

aso
Posts: 2
Joined: Fri Jun 19, 2015 12:43 pm

Re: Error while detecting Wkhtml version

Post by aso » Thu Jul 18, 2019 2:30 pm

The wkhtml detection is done via
${wkhtmltopdf} -V

In your case:
/usr/local/bin/wkhtmltopdf -V

If that gives an os error the shown message comes up.

openemmy
Posts: 12
Joined: Thu Jun 27, 2019 3:42 pm

Re: Error while detecting Wkhtml version

Post by openemmy » Thu Jul 18, 2019 6:20 pm

Thanks. That helped. I had to reinstall wkhtmltopdf

Post Reply