OpenEMM-Application is NOT running

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

Manoj Sreepada
Posts: 21
Joined: Thu Aug 06, 2020 1:32 pm

Re: OpenEMM-Application is NOT running

Post by Manoj Sreepada » Thu Aug 27, 2020 12:14 pm

Yes, We have Installed OpenEMM frontend, We get the following Error:

Here is the most recent portion of the Catalina.out log:

27-Aug-2020 08:33:24.525 WARNING [main] org.apache.catalina.startup.Catalina.load Unable to load server configuration from [/home/openemm/tomcat9/conf/server.xml]
java.io.FileNotFoundException: /home/openemm/tomcat9/conf/server.xml (No such file or directory)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(FileInputStream.java:195)
at java.io.FileInputStream.<init>(FileInputStream.java:138)
at java.io.FileInputStream.<init>(FileInputStream.java:93)
at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:90)
at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:188)
at org.apache.catalina.startup.CatalinaBaseConfigurationSource.getResource(CatalinaBaseConfigurationSource.java:107)
at org.apache.tomcat.util.file.ConfigurationSource.getConfResource(ConfigurationSource.java:92)
at org.apache.tomcat.util.file.ConfigurationSource.getServerXml(ConfigurationSource.java:69)
at org.apache.catalina.startup.CatalinaBaseConfigurationSource.getServerXml(CatalinaBaseConfigurationSource.java:51)
at org.apache.catalina.startup.Catalina.load(Catalina.java:561)
at org.apache.catalina.startup.Catalina.load(Catalina.java:607)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:304)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:474)
27-Aug-2020 08:33:24.531 SEVERE [main] org.apache.catalina.startup.Catalina.start Cannot start server, server instance is not configured
27-Aug-2020 08:49:36.303 WARNING [main] org.apache.catalina.startup.Catalina.load Unable to load server configuration from [/home/openemm/tomcat9/conf/server.xml]
java.io.FileNotFoundException: /home/openemm/tomcat9/conf/server.xml (No such file or directory)
at java.io.FileInputStream.open0(Native Method)
at java.io.FileInputStream.open(FileInputStream.java:195)
at java.io.FileInputStream.<init>(FileInputStream.java:138)
at java.io.FileInputStream.<init>(FileInputStream.java:93)
at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:90)
at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:188)
at org.apache.catalina.startup.CatalinaBaseConfigurationSource.getResource(CatalinaBaseConfigurationSource.java:107)
at org.apache.tomcat.util.file.ConfigurationSource.getConfResource(ConfigurationSource.java:92)
at org.apache.tomcat.util.file.ConfigurationSource.getServerXml(ConfigurationSource.java:69)
at org.apache.catalina.startup.CatalinaBaseConfigurationSource.getServerXml(CatalinaBaseConfigurationSource.java:51)
at org.apache.catalina.startup.Catalina.load(Catalina.java:561)
at org.apache.catalina.startup.Catalina.load(Catalina.java:607)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:304)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:474)
27-Aug-2020 08:49:36.305 SEVERE [main] org.apache.catalina.startup.Catalina.start Cannot start server, server instance is not configured
27-Aug-2020 10:23:30.900 WARNING [main] org.apache.catalina.startup.Catalina.load Unable to load server configuration from [/home/openemm/tomcat9/conf/server.xml]

Thanks, Please Advice for any help.

maschoff
Site Admin
Posts: 2493
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: OpenEMM-Application is NOT running

Post by maschoff » Thu Aug 27, 2020 12:21 pm

Something seems to be wrong with your installation:

java.io.FileNotFoundException: /home/openemm/tomcat9/conf/server.xml (No such file or directory)
OpenEMM Maintainer

Manoj Sreepada
Posts: 21
Joined: Thu Aug 06, 2020 1:32 pm

Re: OpenEMM-Application is NOT running

Post by Manoj Sreepada » Thu Aug 27, 2020 12:30 pm

What can we do?

java.io.FileNotFoundException: /home/openemm/tomcat9/conf/server.xml (No such file or directory)

Thanks, Please Advice for any help.

maschoff
Site Admin
Posts: 2493
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: OpenEMM-Application is NOT running

Post by maschoff » Thu Aug 27, 2020 12:34 pm

Maybe a symlink is missing? You could compare your installation to the installation in the OVA file for missing directories, files or symlinks.
OpenEMM Maintainer

Manoj Sreepada
Posts: 21
Joined: Thu Aug 06, 2020 1:32 pm

Re: OpenEMM-Application is NOT running

Post by Manoj Sreepada » Thu Aug 27, 2020 12:56 pm

We get the following error:

Catalina.out log:

27-Aug-2020 11:48:20.927 INFO [main] org.apache.catalina.core.AprLifecycleListener.lifecycleEvent The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: [/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib]

maschoff
Site Admin
Posts: 2493
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: OpenEMM-Application is NOT running

Post by maschoff » Thu Aug 27, 2020 1:02 pm

This is not an error, just for INFO.
OpenEMM Maintainer

Manoj Sreepada
Posts: 21
Joined: Thu Aug 06, 2020 1:32 pm

Re: OpenEMM-Application is NOT running

Post by Manoj Sreepada » Sat Aug 29, 2020 6:54 pm

Hello,

we get the following error:

DB Connection cannot be established. (Maybe DB user or DB connection parameters for OpenEMM were not configured)
DB structure does not exist. (Maybe OpenEMM is not installed)

Thanks,

Post Reply