OpenENN 2015 problems after upgrade

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

osc
Posts: 1
Joined: Tue Oct 14, 2014 3:17 pm

OpenENN 2015 problems after upgrade

Post by osc » Wed Jun 10, 2015 3:59 pm

Hello together,

I updated our OpenEMM 2013 to 2015 today with the automatic update.
That all works fine.

I am running OpenEMM on Centos 5.6 32-bit with Tomcat 6 and Java 7.

The first problem is that the preview function is not working.
It shows this error: Error in dyn tags.

Logfile output:
2015-06-10 16:16:16,964: ERROR [http-8080-1] org.agnitas.util.SafeString - getLocaleString (key: preview.error.empty, locale: de_DE)
java.util.MissingResourceException: Can't find resource for bundle java.util.PropertyResourceBundle, key preview.error.empty
at java.util.ResourceBundle.getObject(ResourceBundle.java:395)
at java.util.ResourceBundle.getObject(ResourceBundle.java:392)
at java.util.ResourceBundle.getString(ResourceBundle.java:355)
at org.agnitas.util.SafeString.getLocaleString(SafeString.java:380)
at org.agnitas.web.MailingSendAction.analyzePreviewError(MailingSendAction.java:1197)
at org.agnitas.web.MailingSendAction.getPreview(MailingSendAction.java:910)
at org.agnitas.web.MailingSendAction.execute(MailingSendAction.java:457)
at org.springframework.web.struts.DelegatingActionProxy.execute(DelegatingActionProxy.java:113)
at org.apache.struts.chain.commands.servlet.ExecuteAction.execute(ExecuteAction.java:58)
at org.apache.struts.chain.commands.AbstractExecuteAction.execute(AbstractExecuteAction.java:67)
at org.apache.struts.chain.commands.ActionCommandBase.execute(ActionCommandBase.java:51)
at org.apache.commons.chain.impl.ChainBase.execute(ChainBase.java:191)
at org.apache.commons.chain.generic.LookupCommand.execute(LookupCommand.java:305)
at org.apache.commons.chain.impl.ChainBase.execute(ChainBase.java:191)
at org.apache.struts.chain.ComposableRequestProcessor.process(ComposableRequestProcessor.java:283)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:449)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.agnitas.web.filter.Struts1SecurityFilter.doFilter(Struts1SecurityFilter.java:106)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)

The second problem when I am starting openemm.sh


Stopping obsolete sendmail processes: /home/openemm/bin/mailer.sh: line 38: /home/openemm/bin/smctrl: cannot execute binary file
done.
Starting sendmails: listener /home/openemm/bin/mailer.sh: line 50: /home/openemm/bin/smctrl: cannot execute binary file
mail queues /home/openemm/bin/mailer.sh: line 52: /home/openemm/bin/smctrl: cannot execute binary file
ADMIN /home/openemm/bin/mailer.sh: line 79: /home/openemm/bin/smctrl: cannot execute binary file
/home/openemm/bin/mailer.sh: line 79: /home/openemm/bin/smctrl: cannot execute binary file
QUEUE /home/openemm/bin/mailer.sh: line 79: /home/openemm/bin/smctrl: cannot execute binary file
/home/openemm/bin/mailer.sh: line 79: /home/openemm/bin/smctrl: cannot execute binary file
MIDQUEUE /home/openemm/bin/mailer.sh: line 79: /home/openemm/bin/smctrl: cannot execute binary file
SLOWQUEUE /home/openemm/bin/mailer.sh: line 79: /home/openemm/bin/smctrl: cannot execute binary file
/home/openemm/bin/mailer.sh: line 83: /home/openemm/bin/qctrl: cannot execute binary file
/home/openemm/bin/mailer.sh: line 84: /home/openemm/bin/qctrl: cannot execute binary file
/home/openemm/bin/mailer.sh: line 85: /home/openemm/bin/qctrl: cannot execute binary file

Hope you can help me :-)

maschoff
Site Admin
Posts: 2204
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: OpenENN 2015 problems after upgrade

Post by maschoff » Wed Jun 10, 2015 9:02 pm

The binary tarball available at SourceForge was compiled for 64 bit Linux. See instructions for a fix here:
https://sourceforge.net/projects/openem ... /Bugfixes/
OpenEMM Maintainer

Post Reply