bav-update.log errors...

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

lokkju
Posts: 3
Joined: Sat Aug 26, 2006 6:58 pm

bav-update.log errors...

Post by lokkju » Sat Aug 26, 2006 8:51 pm

In adition to the sendmail erros from my prevous post, I am getting this, in the <date>-bav-update.log file:

Code: Select all

[26.08.2006  12:46:39] 15232 ERROR/data: Unable to get database cursor
[26.08.2006  12:46:39] 15232 ERROR/data: Update failed: readDatabase.cursor
It looks as if the python script is not being able to connect to the MySQL database, even though the web interface is...

Again, this is CentOS 4

Ronin
Posts: 8
Joined: Thu Sep 21, 2006 1:53 am
Location: USA

Similar errors in other logs

Post by Ronin » Thu Sep 21, 2006 2:03 am

I'm having the same issue on RHEL
Similar errors, all related to database cursor, in pickdist.log and update.log and the mailing never goes.
Everything else is running perfectly.
In one it's an "ERROR/Loop"
In another it's an "ERROR/Scan"
It's like the scripts aren't connecting to the database so the final mailing isn't assembled and moved to the QUEUE for pickup by the Sendmail Queue runner.

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Thu Sep 21, 2006 8:59 am

This looks like the python database driver is installed, but it cannot connect to the database. Try these steps for more details:

Code: Select all

{login as openemm}
% . bin/scripts/config.sh
% python
>>> import agn
>>> db = agn.DBase ()
>>> db
{this should output something like <agn.DBase instance at 0xb7e9986c>}
>>> cursor = db.newInstance ()
>>> cursor
{this should output something like <agn.DBase instance at 0xb7e9986c>}
If there is no output in the last case, some error has occured. Then please enter this command at your python prompt:

Code: Select all

>>> db.lasterr.args
and have a look at this output.

-- ud

Ronin
Posts: 8
Joined: Thu Sep 21, 2006 1:53 am
Location: USA

Post by Ronin » Fri Sep 22, 2006 5:42 pm

at >>>db.lasterr.args I get
(1045, "Access denied for user "agnitus'@'localhost' (using password: YES")
Have set and reset MySQL permissions but situation is unchanged
Everything else works fine.

ud
Posts: 141
Joined: Thu Aug 17, 2006 9:56 am
Location: Munich, Germany
Contact:

Post by ud » Mon Sep 25, 2006 7:41 am

Ronin wrote: (1045, "Access denied for user "agnitus'@'localhost' (using password: YES")
agnitus? Are you sure? The correct user is agnitas.

-- ud

Ronin
Posts: 8
Joined: Thu Sep 21, 2006 1:53 am
Location: USA

Post by Ronin » Mon Sep 25, 2006 2:28 pm

Sorry, must have had numbfingers. Yes, it's 'agnitas'

Post Reply