Upgrading 2013 to 2015

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

jetNEXUS
Posts: 2
Joined: Thu Apr 09, 2015 12:03 pm

Upgrading 2013 to 2015

Post by jetNEXUS » Thu Apr 09, 2015 12:07 pm

Hi All,

Trying to run the update through the GUI and it seem to be falling at the first hurdle, can anyone please assist me with this?

Code: Select all

Update process starting up
Trying to determinate current running version
Found "2013" as current active version
Looking for new version on remote server (this may take some time)
Found version 2015 on server
Current version is 2013, new version 2015, starting update now
Trying to fetch the new version from one of these URLs:
http://cznic.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://tcpdiag.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://internode.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://heanet.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://tenet.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://nchc.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://nchc.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://dfn.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://softlayer-ams.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://iweb.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
http://aarnet.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
Be patient, this may take several minutes ...
Trying to download file http://cznic.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz
Downloading 88.452 kByte
Download of http://cznic.dl.sourceforge.net/project/openemm/OpenEMM%20software/OpenEMM%202015/OpenEMM-2015-bin.tar.gz successful
Trying to store the new version to /tmp/OpenEMM-2015-bin.tar.gz
Stopping running instance
   Shutting down Tomcat ......
   Waiting for shutdown of Tomcat:..........Terminating Tomcat the hard way with kill -9 3330
   .
   Stop scripts/slrtscn.py program .. done.
   Stop /home/openemm/bin/qctrl program with signal 15 .. done.
   Stop all sendmail processes: Shutting down sm-client: [FAILED]
   Shutting down sendmail: [ OK ]
   -15:3221 -15:3230 -15:3240 -15:3250 -15:3260 -15:3270 -15:3280Shutting down sendmail: [FAILED]
   Starting sendmail: WARNING: Xbav: local socket name /home/openemm/var/run/bav.sock missing
   [ OK ]
   Starting sm-client: [ OK ]
   done.
   Stop scripts/pickdist program .. done.
   Stop scripts/update.py program .. done.
   Stop scripts/bavd program .. done.
   Stop scripts/bav-trigger program with signal 15 .. done.
   Stop scripts/bav-update program with signal 15 .. done.
Renaming current version to keep as archive
Unpacking new version
   sh: /home/openemm/bin/updater: cannot execute binary file
Unable to set correct permissions

maschoff
Site Admin
Posts: 2204
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Upgrading 2013 to 2015

Post by maschoff » Thu Apr 09, 2015 5:43 pm

Please check the mentioned file updater in directory /home/openemm/bin. It must be set to group root and user root. Otherwise it will not be able to do its job due to missing rights.
OpenEMM Maintainer

jetNEXUS
Posts: 2
Joined: Thu Apr 09, 2015 12:03 pm

Re: Upgrading 2013 to 2015

Post by jetNEXUS » Fri Apr 10, 2015 10:56 am

Hi Maschoff,

I've checked the rights on that file and they are correct, will group and user root, but I'm still getting this issue. Anywhere else I can look?

maschoff
Site Admin
Posts: 2204
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Upgrading 2013 to 2015

Post by maschoff » Fri Apr 10, 2015 3:26 pm

In this case you should finish the update manually.
OpenEMM Maintainer

Post Reply