Error after updating from 2011 to 2013 - recipient list

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

walter_gl
Posts: 4
Joined: Tue Feb 26, 2013 7:48 pm

Error after updating from 2011 to 2013 - recipient list

Post by walter_gl » Tue Feb 26, 2013 8:01 pm

after an update from 2011 to 2013, we get the following error message: "ERROR: Resource key "error.errorneous_recipient_search" not found in default bundle" when calling the recipient list

from the manual 2013:
Please note: OpenEMM displays a maximum of 10,000 entries in the recipient list as standard.
This value can be modified in company_tbl.max_recipients.
If the number of available recipients is too large, the program only displays the first page and by
means of an message makes you aware that the displayed selection must be limited.


Now we have changed the number of max_recipients in company_tbl from 10000 to 20000 (we have 15000 recipients) but nothing happens. the error message is still there and no recipients are displayed, also when we limited the selection :oops:

many thx for ideas and help

maschoff
Site Admin
Posts: 2224
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Error after updating from 2011 to 2013 - recipient list

Post by maschoff » Wed Feb 27, 2013 1:17 pm

Quick fix: Open file messages.properties in directory /home/openemm/webapps/openemm/WEB-INF/classes and add line

Code: Select all

error.errorneous_recipient_search=Your recipient search resulted in an error
at the end.
OpenEMM Maintainer

walter_gl
Posts: 4
Joined: Tue Feb 26, 2013 7:48 pm

Re: Error after updating from 2011 to 2013 - recipient list

Post by walter_gl » Thu Feb 28, 2013 10:42 am

Nice Joke :x sorry very quick, but thx for your comment, any better help or fix??

Now we have a new error message, but we can't display any recipients. Only when we limte the search request to display only admin's (two accounts) we got an result.

maschoff
Site Admin
Posts: 2224
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Error after updating from 2011 to 2013 - recipient list

Post by maschoff » Thu Feb 28, 2013 10:57 am

This error is only shown if the result set is empty. Please check the log catalina.out for an internal error message.
OpenEMM Maintainer

walter_gl
Posts: 4
Joined: Tue Feb 26, 2013 7:48 pm

Re: Error after updating from 2011 to 2013 - recipient list

Post by walter_gl » Thu Feb 28, 2013 12:02 pm

The request is defenitiv not empty

Line from the log file catalina.out:

  Hibernate: select profilefie0_.company_id as company1_21_, profilefie0_.col_name as col2_21_, profilefie0_.admin_id as admin3_21_, profilefie0_.shortname as shortname21_, profilefie0_.description as descript5_21_, profilefie0_.default_value as default6_21_, profilefie0_.mode_edit as mode7_21_, profilefie0_.mode_insert as mode8_21_ from customer_field_tbl profilefie0_ where profilefie0_.company_id =?

The bug is reproducible. In the VM version 2011 after the update to 2013 (with the same database) is the error back.

walter_gl
Posts: 4
Joined: Tue Feb 26, 2013 7:48 pm

Re: Error after updating from 2011 to 2013 - recipient list

Post by walter_gl » Thu Feb 28, 2013 1:45 pm

After we have checked everything again and we have created a new database and imported the data (and only the data) again, there are not longer errors. The update must have changed the database or destroyed it.

But it would be great, if somebody can comment the log-file entry above

:lol:

mmaaeexx
Posts: 1
Joined: Wed Apr 10, 2013 8:29 am

Re: Error after updating from 2011 to 2013 - recipient list

Post by mmaaeexx » Wed Apr 10, 2013 8:47 am

hello

has anyone solved the "ERROR: Resource key "error.errorneous_recipient_search" - problem?
we have the same problem. but it show up only with some of the mailing lists.

catalina.out says:

Code: Select all

Hibernate: select profilefie0_.company_id as company1_21_, profilefie0_.col_name as col2_21_, profilefie0_.admin_id as admin3_21_, profilefie0_.shortname as shortname21_, profilefie0_.description as descript5_21_, profilefie0_.default_value as default6_21_, profilefie0_.mode_edit as mode7_21_, profilefie0_.mode_insert as mode8_21_ from customer_field_tbl profilefie0_ where profilefie0_.company_id=?

maschoff
Site Admin
Posts: 2224
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Error after updating from 2011 to 2013 - recipient list

Post by maschoff » Wed Apr 10, 2013 9:04 am

Quick fix: Open file messages.properties and add

Code: Select all

error.errorneous_recipient_search=Your recipient search resulted in an error
at the end.
OpenEMM Maintainer

Post Reply