Database Connectivity Problem

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

senthilcse
Posts: 28
Joined: Tue Sep 04, 2012 2:18 pm

Database Connectivity Problem

Post by senthilcse » Fri Dec 28, 2012 3:47 pm

Hi,

We are using Openemm 6.2. Today morning onwards its stopped for working. It show following error

An error occurred
Cause: javax.servlet.ServletException: org.springframework.jdbc.BadSqlGrammarException: Hibernate operation: could not execute query; bad SQL grammar [select emmlayout0_.layout_id as layout1_6_, emmlayout0_.company_id as company2_6_, emmlayout0_.header_url as header3_6_, emmlayout0_.footer_url as footer4_6_, emmlayout0_.base_url as base5_6_, emmlayout0_.normal_color as normal6_6_, emmlayout0_.highlight_color as highlight7_6_ from emm_layout_tbl emmlayout0_ where emmlayout0_.company_id=0 and emmlayout0_.layout_id=?]; nested exception is com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'openemm.emm_layout_tbl' doesn't exist

We tried following steps but there is no improvements

1.Database repaired.
2.Table deleted and uploaded new one.
3.We granted all privileged for agnitas user.
3. MYSQL and openemm are restarted.

Please help us to proceed further.

Thanks

maschoff
Site Admin
Posts: 2166
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Database Connectivity Problem

Post by maschoff » Fri Dec 28, 2012 8:09 pm

The error message you posted indicates that OpenEMM database table "emm_layout_tbl" no longer exists. You should check why this table is missing.
OpenEMM Maintainer

Post Reply