Install successful...App does not start

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

sajith
Posts: 1
Joined: Mon Aug 27, 2012 7:44 am

Install successful...App does not start

Post by sajith » Mon Aug 27, 2012 7:50 am

i install bitnami software for mysql and tomcat apache,, openemm install very well and i config my redirect domain to localhost:8080 , but when i go to localhost:8080 it shows apache difault page.. what i have to do , plaese quickly reply , im working on this software instalation 2 days , dindt comup with solution yet, im in my office now pls help mee..
OS->Win7

senthilcse
Posts: 28
Joined: Tue Sep 04, 2012 2:18 pm

Re:[Solved] Install successful...App does not start

Post by senthilcse » Thu Sep 06, 2012 9:02 am

we have installed the following softwares successfully:

1.OpenEMM-2011-win32
2.python-2.7.3
3.MySQL-python-1.2.3.win32-py2.7
4.apache tomcat 6.0.35

Installation process:

1.Install all the above software as per the list i given. when you run the apache tomcot dont install it into the path:"c:\program files\apache software foundation\tomcat6.0" instead of this crteate a folder as "tomcat" in which you will install apache tomcat.

2. This very important step:

after install the apache tomcat 6.0.35,see the bin folder inside 'c:\tomcat\bin' where you cant see start.batch,statr.sh file,because
in apache tomcat 6.0.35 windows installer.exe doesnt have start.batch,statr.sh file.these files are running automatically.
but we need these files to run our openemm software. so you are going to download "http://tomcat.apache.org/download-60.cgi" where under 6.0.35->Binary Distributions->core->32-bit Windows zip (pgp, md5)

unzip the 32-bit Windows zip (pgp, md5) into sepearte folder where you will copy the files which are comes under the "bin" folder.

now go to "c:\tomcat\bin" paste the copied files if anything asks to replace give yes

now you have completed. run the setup.batch file in 'c:openemm' first console window asking about openemm details,then redirection domin url,and so on, aftre getting congratulation message

now run the start.batch file in 'c:openemm' two consecutive console window open with some execution information wait 3 or 5 secs ..then open the browser give the redirection url e.'http://localhost:8080' which is redirect into openemm index.html page. you are complete the openemm installation.

maschoff
Site Admin
Posts: 2165
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Install successful...App does not start

Post by maschoff » Fri Oct 12, 2012 3:38 pm

Very helpful, thank you!
OpenEMM Maintainer

Kabbedijk
Posts: 1
Joined: Thu Nov 01, 2012 12:11 pm

Re: Install successful...App does not start

Post by Kabbedijk » Thu Nov 01, 2012 12:20 pm

The big problem here is the two different version of Tomcat 6 offered for Windows. You can choose to download and extract the .zip file, but you can also choose to download the installer.

The installer will not work with OpenEMM. If you download and extract the .zip file, everything will work fine.

honeyjunjunxia
Posts: 2
Joined: Fri Nov 02, 2012 8:57 am

Re: Install successful...App does not start

Post by honeyjunjunxia » Fri Nov 02, 2012 9:12 am

hi,I met the same problem with yous.
Have you resolved your question?
Help~~~

honeyjunjunxia
Posts: 2
Joined: Fri Nov 02, 2012 8:57 am

Re: Re:[Solved] Install successful...App does not start

Post by honeyjunjunxia » Fri Nov 02, 2012 9:16 am

I haved obeyed all the rules,but it still does not work.
It just shows starting up..............warnings:no mysql found using reg.key......................
help~!help~~
senthilcse wrote:we have installed the following softwares successfully:

1.OpenEMM-2011-win32
2.python-2.7.3
3.MySQL-python-1.2.3.win32-py2.7
4.apache tomcat 6.0.35

Installation process:

1.Install all the above software as per the list i given. when you run the apache tomcot dont install it into the path:"c:\program files\apache software foundation\tomcat6.0" instead of this crteate a folder as "tomcat" in which you will install apache tomcat.

2. This very important step:

after install the apache tomcat 6.0.35,see the bin folder inside 'c:\tomcat\bin' where you cant see start.batch,statr.sh file,because
in apache tomcat 6.0.35 windows installer.exe doesnt have start.batch,statr.sh file.these files are running automatically.
but we need these files to run our openemm software. so you are going to download "http://tomcat.apache.org/download-60.cgi" where under 6.0.35->Binary Distributions->core->32-bit Windows zip (pgp, md5)

unzip the 32-bit Windows zip (pgp, md5) into sepearte folder where you will copy the files which are comes under the "bin" folder.

now go to "c:\tomcat\bin" paste the copied files if anything asks to replace give yes

now you have completed. run the setup.batch file in 'c:openemm' first console window asking about openemm details,then redirection domin url,and so on, aftre getting congratulation message

now run the start.batch file in 'c:openemm' two consecutive console window open with some execution information wait 3 or 5 secs ..then open the browser give the redirection url e.'http://localhost:8080' which is redirect into openemm index.html page. you are complete the openemm installation.

motorcycletalk
Posts: 4
Joined: Wed Feb 06, 2013 6:27 am

Re: Install successful...App does not start

Post by motorcycletalk » Wed Feb 06, 2013 6:35 am

I tried doing this on a windows install for our website http://www.motorcyclemarket.com/brands.aspxand almost went crazy. Then we moved over to a linux installation on centos and it works 1000 times better and the operating system was free. let me know if you need some help to convert this over. Hope it all works out otherwise. :!:

Post Reply