unsubscribe - noob

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

smj
Posts: 2
Joined: Fri Feb 19, 2010 2:48 pm

unsubscribe - noob

Post by smj » Fri Feb 19, 2010 2:58 pm

Hello folks,

I'm having trouble with the unsubscribe link. I have followed the user manual and made a form called UnsubscribeQuery with the following content;

<form action="form.do" method="post">
<input type="hidden" name="agnCI" value="1">
<input type="hidden" name="agnFN" value="OptOutConfirm">
<input type="hidden" name="agnUID" value="$!agnUID">
Do you really want to unsubscribe?<br>
<input type="reset" value="Cancel">
<input type="submit" value="Unsubscribe">
</form>
_________________

Action is set to Load Recipient-data

I then made a confirm form called OptOutQuestion to confirm unsubscribe request, action is set to user_unsubscribe

I then added the link to the content of the mailing;

You can unsubscribe from promotional emails <a href="http://domain.com/form.do?agnCI=1&agnFN ... #">here</a>

when you click the link it returns; "can not display web page" error on the url; http://domain.com:8080/r.html?uid=1.c.4.1q.khm0mm06g1

I noticed the alt http port was coded in there so i also tried http://emm.saq.net/r.html?uid=1.c.4.1q.khm0mm06g1 but again got a page can not be displayed error. I just followed the manual and have checked my code which looks good so I don't know what could be wrong. Thanks in advace for any help offered.

SMJ

maschoff
Site Admin
Posts: 2212
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Fri Feb 19, 2010 8:13 pm

I will show you how the unsubscribe process for the OpenEMM newsletter baiscally works.

1. Unsubscribe link in newsletter:

Code: Select all

http://www.openemm.org:8080/form.do?agnCI=1&agnFN=unsubscribe&agnUID=##AGNUID##
2. Unsubscribe form:

Action: 1. step: Load Recipient Data

Code: Select all

<form name="unsubform" action="form.do" method="post">
<input type="hidden" name="agnCI" value="1">
<input type="hidden" name="agnFN" value="unsubconfirm">
<input type="hidden" name="agnUID" value="$!agnUID">
<input type="submit" value="Unsubscribe">
</form>
3. Unsubconfirm form

Action: 1. step: Unsubscribe

Code: Select all

Unsubscribe confirmed.
OpenEMM Maintainer

MartinBerlin
Posts: 4
Joined: Sat Feb 20, 2010 9:44 am

Post by MartinBerlin » Sat Feb 20, 2010 9:49 am

Hello ma!

Thanks for your advice. However I do something the wrong way.

I entered http://[OURSERVERNAME]:8080/form.do?agnCI=1&agnFN=unsubscribe&agnUID=##AGNUID## into the HTML and text body of a test mailing. Exactly this string appears in the final mail. Those IDs won't be replaced by specific user IDs. I think this is one my problems with the unsubscription process.

Next I looked up the action section and found six forms already there. Among others, there are doi_user_confirm and user_unsubscribe. So, I guess I don't have to do anything there. Am I right?

Thanks for all your help in advance

Martin

maschoff
Site Admin
Posts: 2212
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Sat Feb 20, 2010 11:21 am

Did you enter the string for your redirect domain in field rdir_domain of table company_tbl?
OpenEMM Maintainer

MartinBerlin
Posts: 4
Joined: Sat Feb 20, 2010 9:44 am

Post by MartinBerlin » Sat Feb 20, 2010 12:00 pm

My fault, I called up a form which wasn't there (wrong name). Everything seems to work fine.

Thanks!

maschoff
Site Admin
Posts: 2212
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Post by maschoff » Sat Feb 20, 2010 5:39 pm

Great! :-)
OpenEMM Maintainer

nikopol484
Posts: 7
Joined: Fri Mar 06, 2015 12:03 pm

Re: unsubscribe - noob

Post by nikopol484 » Wed Mar 18, 2015 11:26 am

Hello everyone. I have a trouble with unsubscribe link.
My server have not access with www.servername.com, only by servername.com.
When I add unsubscribe link by manual and set in company_tbl redirection domain to www.servername.com - link generates successfully, but it point to nowhere because server dont answer on www at start.
So I changed redirection domain to servername.com and unsubscribe link dont generated.
Where is a problem? openemm checking domain name by some regexp? If check - how can I disable or modify it?

Post Reply