Mysqladmin is a recognized internal or external command...

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

eclectica
Posts: 1
Joined: Tue Mar 03, 2009 2:31 am
Location: Portland
Contact:

Mysqladmin is a recognized internal or external command...

Post by eclectica » Tue Mar 03, 2009 4:26 am

I am trying to install OpenEMM on a Windows XP Home machine.

I have installed Python, MySQL, and the MySQL-Python tools as per instructions.

When I run the setup it tells me to enter the root password, but does not give me time to enter it, instead giving the error 'Mysqladmin is a recognized internal or external command...'

I read on a closed post this had something to do with users who did not use the suggested install path but would be fixed on the latest release.

I have the latest release of OpenEMM.

I tried using the default directory which on my machine automatically goes to the D: drive. I altered the registry to do this when I first got my computer as I install everything on that drive.

Then I uninstalled MySQL and reinstalled it onto the C: drive. This did not work either.

Any suggestions?

AnzaSystems
Posts: 2
Joined: Wed May 20, 2009 6:52 am

Installation

Post by AnzaSystems » Wed May 20, 2009 7:01 am

u must use Mysql version 5.0 then this error will remove

Kiley Love
Posts: 3
Joined: Fri Apr 12, 2013 10:16 pm

Re: Mysqladmin is a recognized internal or external command.

Post by Kiley Love » Fri Apr 12, 2013 10:23 pm

I had the same problem,

Here is what I did to fix it

run regedit
navigate to HKEY_USERS
navigate to user id (usually a string such as S-1-5-21-##########-##########-##########-####)
navigate to software
navigate to MySQL AB
navigate to MySQL Server 5.x
insert new string value (right click > new > string value)
name new string value "location"
modify new string value ( right click on "location" > select modify... )
enter path to MySQL Server 5.x\bin
mine was C:\Program Files\MySQL\MySQL Server 5.6\bin
click ok
go back to openemm and run setup.bat
worked for me.

this was pretty frustrating until I discovered that setup.bat doesn't use the windows environment path, instead it uses the registry setting, my installation of MySQL didn't put the location in the registry setting, so I had to manually enter it using the steps above. Hope this helps all those who run into the same problem on a windows install of OpenEMM...

Post Reply