Upgrade from OpenEMM 2015 R2

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

tgeseron
Posts: 1
Joined: Tue May 10, 2022 8:36 pm

Upgrade from OpenEMM 2015 R2

Post by tgeseron » Tue May 10, 2022 8:40 pm

We are running OpenEMM 2015 R2 on Ubuntu 14.04.6 LTS

This was setup well before my time and was left as is. What we would like to do is:

1) Upgrade the OS
2) Upgrade OpenEMM to a new / supported version
3) Setup links to use HTTPS instead of HTTP://8080 (which redirect to our survey tool on HTTPS)
4) Stay current with OpenEMM versions to prevent this out of date issue from happening in the future.

We only have a couple of linux VMs and limited experience with OpenEMM... what is our path forward? Can we do in-place upgrades to OpenEMM to get on a new version? Is there an export/import that should be done instead to a new server?

Thanks!

maschoff
Site Admin
Posts: 2529
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: Upgrade from OpenEMM 2015 R2

Post by maschoff » Thu May 12, 2022 6:24 pm

Please check this thread: viewtopic.php?f=2&t=7687
OpenEMM Maintainer

Post Reply