DB Error after updating to 21.04.000.080 - or not?

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

Andrey
Posts: 42
Joined: Wed Jun 21, 2017 12:13 pm

DB Error after updating to 21.04.000.080 - or not?

Post by Andrey » Thu Jun 03, 2021 4:15 pm

Hello,
Today updated to the new version of OpenEmm!
Thank's a lot for great application!
Looks like all working fine but in the System Status - Db Error - Missing DB 21.04.000.


In the console the system status:
OpenEMM Version: 21.04.000.080
OpenEMM database structure exists (Version 21.04.000.079)

Code: Select all

=============================================
= OpenEMM Maintenance Tool (OMT) v21.04.071 =
=============================================
Root mode: On
Hostname: OpenEmm
OpenEMM License: OpenEMM (ID: 0)
OpenEMM Runtime Version: 21.04.072
OpenEMM Version: 21.04.000.080
OpenEMM Manual Version: 21.01.005
System-Url: 

Current menu: Show OpenEMM status

OpenEMM status:
Operating System (OS): CentOS 7
Python version: 3.8.3 (default, May 15 2020, 01:26:50)  [GCC 4.8.5 20150623 (Red Hat 4.8.5-39)]
Sendmail Version: 0.11.1
Postfix Version: 2.10.1
DB client version: /opt/rh/rh-mariadb102/root/usr/bin/mysql  Ver 15.1 Distrib 10.2.33-MariaDB, for Linux (x86_64) using  EditLine wrapper
Database Connection: OK
System-Time: 2021-06-03 18:11:33
System-Time-DB: 2021-06-03 18:11:33
Database version: MariaDB 10.2.33-MariaDB
OpenEMM database structure exists (Version 21.04.000.079)
Database table emm_db_errorlog_tbl: OK
Jobqueue status: OK
DKIM keys available for domains: None
Java version: 1.8.0_292 (Oracle)
Tomcat version: 9.0.45.0
Tomcat-Native version: 1.2.23
Wkhtml version: wkhtmltopdf 0.12.5 (with patched qt)
OpenEMM Application is running (Tomcat ProcessID: 31917, started at: 17:19 6:25)
OpenEMM Backend ok: once
OpenEMM Backend running: mailout, update, trigger, generate, mta, pickdist, slrtscn, direct-path, bav-update, bavd, bav, mlcontrol

The Job DBcheck - works without error.

Is there any problem or only wrong status of db check


Best Regards

maschoff
Site Admin
Posts: 2472
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: DB Error after updating to 21.04.000.080 - or not?

Post by maschoff » Sat Jun 05, 2021 11:38 am

Where exactly do you see error message "Missing DB 21.04.000"?
OpenEMM Maintainer

Andrey
Posts: 42
Joined: Wed Jun 21, 2017 12:13 pm

Re: DB Error after updating to 21.04.000.080 - or not?

Post by Andrey » Mon Jun 07, 2021 9:40 am

Hi!
maschoff wrote:
Sat Jun 05, 2021 11:38 am
Where exactly do you see error message "Missing DB 21.04.000"?
It's at the System Status page at the Front End:
Image sorry http only

maschoff
Site Admin
Posts: 2472
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: DB Error after updating to 21.04.000.080 - or not?

Post by maschoff » Mon Jun 07, 2021 10:40 am

Thanks, we can reproduce now and will take care.
OpenEMM Maintainer

maschoff
Site Admin
Posts: 2472
Joined: Thu Aug 03, 2006 10:20 am
Location: Munich, Germany
Contact:

Re: DB Error after updating to 21.04.000.080 - or not?

Post by maschoff » Mon Jun 07, 2021 3:00 pm

You can download update 21.04.000.088 with OMT now. Please check. Works for me.
OpenEMM Maintainer

Andrey
Posts: 42
Joined: Wed Jun 21, 2017 12:13 pm

Re: DB Error after updating to 21.04.000.080 - or not?

Post by Andrey » Tue Jun 08, 2021 8:53 am

Hi!
maschoff wrote:
Mon Jun 07, 2021 3:00 pm
You can download update 21.04.000.088 with OMT now. Please check. Works for me.
Yes it's working!
Thank you very much!!

Post Reply