Graphical customization

Use this forum for questions regarding installation, upgrading and configuration of OpenEMM

Moderator: moderator

andrearossi
Posts: 20
Joined: Mon Dec 21, 2020 11:30 am

Graphical customization

Post by andrearossi » Mon Feb 15, 2021 9:59 am

Hello, I would like to change some icons and text to customize my installation, for example the top-left block (logo + OpenEMM FALL 2020).
I don't actually know if this stuff is somehow "fixed" after the compiling of Java code, that would mean I have to do the edits before installing, and I'd have to clone your repo instead of use the binary installer?
By the way, checking some files, I found that in

Code: Select all

release/emm/openemm-gui-20.10.000.107/WEB-INF/jsp/template_jsp.java
you can set that logo, and I managed to change it to an european flag (just to put a random svg image). After restarting the logo stayed mine.
Now, what's strange is that that file is gone, I can't find it anymore even though I don't think I've deleted it. Unfortunately I didn't even copy it to make a backup. So I'm stuck with my flag, lol. Is this normal? Was this the proper way to change that logo? If yes, how can I repeat that process again?
What about the text labels?

@mods: Not sure if this is the right forum section, move this thread if you wish :mrgreen:

andrearossi
Posts: 20
Joined: Mon Dec 21, 2020 11:30 am

Re: Graphical customization

Post by andrearossi » Thu Feb 18, 2021 5:26 pm

I just realized I was looking for the wrong file. Correct one was located in

Code: Select all

release/emm/openemm-gui-20.10.000.107/WEB-INF/jsp/logo.jspf
BTW, is this the proper way to change that logo?

andrearossi
Posts: 20
Joined: Mon Dec 21, 2020 11:30 am

Re: Graphical customization

Post by andrearossi » Mon Mar 15, 2021 9:16 am

Up :)

andrearossi
Posts: 20
Joined: Mon Dec 21, 2020 11:30 am

Re: Graphical customization

Post by andrearossi » Fri Apr 09, 2021 4:41 pm

Bump :D

Miller
Posts: 1
Joined: Sun Apr 11, 2021 9:53 am

Re: Graphical customization

Post by Miller » Sun Apr 11, 2021 10:02 am

andrearossi wrote:
Mon Feb 15, 2021 9:59 am
Hello, I would like to change some icons and text to customize my installation, for example the top-left block (logo + OpenEMM FALL 2020).
I don't actually know if this stuff is somehow "fixed" after the compiling of Java code, that would mean I have to do the edits before installing, and I'd have to clone your repo instead of use the binary installer?
By the way, checking some files, I found that in

Code: Select all

release/emm/openemm-gui-20.10.000.107/WEB-INF/jsp/template_jsp.java
you can set that logo, and I managed to change it to an european flag (just to put a random svg image). After restarting the logo stayed mine.192.168.o.1
Now, what's strange is that that file is gone, I can't find it anymore even though I don't think I've deleted it. Unfortunately I didn't even copy it to make a backup. So I'm stuck with my flag, lol. Is this normal? Was this the proper way to change that logo? If yes, how can I repeat that process again?
What about the text labels?

@mods: Not sure if this is the right forum section, move this thread if you wish :mrgreen:
Hello,
Hello,
I have the same problem. Did you manage to solve it?

andrearossi
Posts: 20
Joined: Mon Dec 21, 2020 11:30 am

Re: Graphical customization

Post by andrearossi » Wed Apr 21, 2021 3:35 pm

Miller wrote:
Sun Apr 11, 2021 10:02 am
andrearossi wrote:
Mon Feb 15, 2021 9:59 am
Hello, I would like to change some icons and text to customize my installation, for example the top-left block (logo + OpenEMM FALL 2020).
I don't actually know if this stuff is somehow "fixed" after the compiling of Java code, that would mean I have to do the edits before installing, and I'd have to clone your repo instead of use the binary installer?
By the way, checking some files, I found that in

Code: Select all

release/emm/openemm-gui-20.10.000.107/WEB-INF/jsp/template_jsp.java
you can set that logo, and I managed to change it to an european flag (just to put a random svg image). After restarting the logo stayed mine.192.168.o.1
Now, what's strange is that that file is gone, I can't find it anymore even though I don't think I've deleted it. Unfortunately I didn't even copy it to make a backup. So I'm stuck with my flag, lol. Is this normal? Was this the proper way to change that logo? If yes, how can I repeat that process again?
What about the text labels?

@mods: Not sure if this is the right forum section, move this thread if you wish :mrgreen:
Hello,
Hello,
I have the same problem. Did you manage to solve it?
Sadly, no. Also this thread seems to have gone unnoticed...

Post Reply