Search found 72 matches

by JuergenB
Mon Oct 04, 2021 7:06 pm
Forum: Bugs, bug fixes & releases
Topic: runtime error 21.10.009 at installation
Replies: 1
Views: 115

runtime error 21.10.009 at installation

Hi, openemm-runtime-21.10.009 has a installation error. After i start OMT.sh at user openemm i want to configure the basic environment. Runtime 21.04.099 is fine, but the new one is ugly ... All if fine, but if i enter Tomcat-Native the Script fails. Has anyone tested the runtime 21.10.009 ? =======...
by JuergenB
Wed Aug 25, 2021 5:00 pm
Forum: Installation & Upgrades
Topic: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04
Replies: 13
Views: 374

Re: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04

Thanks, i tried 21.04 with AlmaLinux 8.4, but 21.04 is not compatible right now... This is what i get after running OMT.sh and configuring the environment. Installation failed. Please install and configure the optional Apache Tomcat Native for Apache Tomcat 9 application manually. See OpenEMM's &quo...
by JuergenB
Tue Aug 24, 2021 12:25 pm
Forum: Installation & Upgrades
Topic: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04
Replies: 13
Views: 374

Python 3.8.8 and mariadb 10.3.28 not supported by 21.04

Hello, during a clean installation with the latest runtime (openemm-runtime-21.04.097.tar.gz) on a clean CentOS8 Stream the installer fails at some parts and OpenEMM complains that mariadb is not supported. OpenEMM status: Operating System (OS): CentOS 8 Python version: 3.8.8 (default, Aug 2 2021, 1...
by JuergenB
Thu Jul 29, 2021 1:09 pm
Forum: Bugs, bug fixes & releases
Topic: OpenEMM 21.04 now available
Replies: 6
Views: 395

Re: OpenEMM 21.04 now available

Can you verifiy your python/mysql verification? It´s only verifiying if mysqlclient is installed and not mariadb client, so i assumes the installer MUST fail on CentOS 8 . pythonmysql="$(${PYTHON} -c 'import MySQLdb' 2>&1)" if [ ! $? -eq 0 ]; then { tput setaf 1 # set text output to re...
by JuergenB
Wed Jul 28, 2021 3:52 pm
Forum: Bugs, bug fixes & releases
Topic: OpenEMM 21.04 now available
Replies: 6
Views: 395

Re: OpenEMM 21.04 now available

Hi, i get the mysqlclient / mariadb error message in a clean installation with runtime 21.04.000.116. [openemm@localhost bin]$ ./OMT.sh Checking python installation ... Python version found: 3.8.8 Mandatory python mysql module is missing! Command to install python mysql module: 'sudo /usr/bin/python...
by JuergenB
Mon Jul 26, 2021 2:11 pm
Forum: Bugs, bug fixes & releases
Topic: OpenEMM 21.04 now available
Replies: 6
Views: 395

Re: OpenEMM 21.04 now available

Thanks, but i installed with admin guide 1.0.3 and the sql client was missing... After starting ./OMT.sh the installer recommended this cmd ... [openemm@localhost bin]$ ./OMT.sh Checking python installation ... Python version found: 3.8.8 Mandatory python mysql module is missing! Command to install ...
by JuergenB
Mon Jul 26, 2021 1:35 pm
Forum: Bugs, bug fixes & releases
Topic: OpenEMM 21.04 now available
Replies: 6
Views: 395

Re: OpenEMM 21.04 now available

Thanks for the new release, I upgraded from 20.04 to 21.04 today and after solving the same problems i have at every upgrade, all is running fine. With every update the owner:group of /home/openemm/tomcat/logs get´s chanegd to root:root and tomcat can´t write into catalina.out So i need to change th...
by JuergenB
Sat Feb 27, 2021 8:21 pm
Forum: Installation & Upgrades
Topic: Foreign key constraint is incorrectly formed
Replies: 3
Views: 729

Re: Foreign key constraint is incorrectly formed

Thanks, i did a DB dump at 20.10 installation and modified the dump process in 20.04. So i was able to dump a database from 20.04 release. Next i dumped the 20.04 database and imported the 20.04 dump within mariadb @ the 20.10 system. I started the rutime 20.10 and did a full reinstall of the backen...
by JuergenB
Mon Feb 22, 2021 4:30 pm
Forum: Installation & Upgrades
Topic: Foreign key constraint is incorrectly formed
Replies: 3
Views: 729

Re: Foreign key constraint is incorrectly formed

I tried again with backup and restore from 20.04 into 20.10 i droped the live db 20.10 and created a empty one to /root/... Next i tried to restore, this failed with an error, so i used the shell and this command. [root@localhost bin]# mysql -u openemm -h localhost openemm -p'********' < /root/opene...
by JuergenB
Mon Feb 22, 2021 3:59 pm
Forum: Installation & Upgrades
Topic: Foreign key constraint is incorrectly formed
Replies: 3
Views: 729

Foreign key constraint is incorrectly formed

Hello, if i want to backup/dump from 20.04 and restore to 20.10 i get this erro message during restore. Foreign key constraint is incorrectly formed Any idea how to fix 20.04 database? ERROR 1005 (HY000) at line 35: Can't create table `openemm`.`actop_content_view_tbl` (errno: 150 "Foreign key ...
by JuergenB
Mon Feb 22, 2021 1:07 pm
Forum: Installation & Upgrades
Topic: OpenEmm 20.10, empty Logfiles in AdministrationSystem StatusShow EMM Logfile
Replies: 1
Views: 601

OpenEmm 20.10, empty Logfiles in AdministrationSystem StatusShow EMM Logfile

Hi,

after a clean Install of 20.04 and Upgrade to 20.10 with CentOs 8 and Java 11 i only see an empty Logfile Screen.

AdministrationSystem -> StatusShow -> EMM Logfile

Is this by design?
by JuergenB
Mon Feb 22, 2021 12:26 pm
Forum: Installation & Upgrades
Topic: Upgrade 20.04 to 20.10 breaks OpenEMM, Overall Status & Jobqueue (RED) / Java Exceptions
Replies: 1
Views: 596

Upgrade 20.04 to 20.10 breaks OpenEMM, Overall Status & Jobqueue (RED) / Java Exceptions

Hi, i have a clean 20.04 Installation on CentOS8 with Python 3.9.0 and Java 11. Fresh Install, no Configration in Web Gui Done and not mailings sent yes. The 20.04 shows Overall Status green and after Upgrading to 20.10 the Overall Status and Jobqueue Status is RED. If i do a clean install of 20.10 ...
by JuergenB
Thu Dec 10, 2020 5:35 pm
Forum: Installation & Upgrades
Topic: New Install openemm-runtime-20.10.070 - Python3 Error
Replies: 15
Views: 2160

Re: New Install openemm-runtime-20.10.070 - Python3 Error

Hi ray, i have a running CentOs 8 with Python 3.9.0, Java 11, MariaDB and OpenEMM 20.10.* I started with the old 19.x Release and migrated / upgraded several times. Most of the time i did a fresh install on a clean evironment. I must admit, that i worked through the Admin Guide 1.3.2 for 20.04 and i...
by JuergenB
Thu Dec 10, 2020 11:21 am
Forum: Installation & Upgrades
Topic: New Install openemm-runtime-20.10.070 - Python3 Error
Replies: 15
Views: 2160

Re: New Install openemm-runtime-20.10.070 - Python3 Error

Hi,

can you try to install with dnf ?

It is the default package manager of Fedora 22, CentOS8 and RHEL8. DNF is the next generation version of YUM and intended to be the replacement for YUM in RPM-based systems.

I have no problems with my script and CentOs 8 so far.
by JuergenB
Fri Dec 04, 2020 8:35 pm
Forum: Installation & Upgrades
Topic: Upgrade from 20.04 to 20.10.070 ('openemm.admin_to_group_tbl' doesn't exist)
Replies: 9
Views: 1375

Re: Upgrade from 20.04 to 20.10.070 ('openemm.admin_to_group_tbl' doesn't exist)

Update, i installed a new OpenEMM 20.04 from scratch on a clean CentOs 8. Here i restored the mariadb Dump from my production CentOS 7 VM. After all was checked, i restartet the services. Only the Overall Status and Jobqueue Status had errors. So reinstalled the 20.04 modules and addons. Finally the...