Search found 51 matches

by JuergenB
Thu Jun 25, 2020 7:15 pm
Forum: Installation & Upgrades
Topic: error in 20.04 sql upgrade script - userrights.sql
Replies: 6
Views: 314

Re: error in 20.04 sql upgrade script - userrights.sql

Thanks aso, the new release works fine, i had no problems during an upgrade from 19.10 to 20.04 with the new runtime. Thanks! :D :D Now, i`ll try to upgrade CentOS 7 to 8 or move mariadb and all config to a new VM ... 8) Didn´t worked well, got some problems after upgrade. Much easier to install 20....
by JuergenB
Wed Jun 24, 2020 4:25 pm
Forum: Installation & Upgrades
Topic: error in 20.04 sql upgrade script - userrights.sql
Replies: 6
Views: 314

Re: error in 20.04 sql upgrade script - userrights.sql

I have a clean, fresh install with 19.10 (and although a production 19.10 i wish to upgrade). So, i have a clean fresh 19.10 running. I do a Install or update package from AGNITAS Website Here i get all the latest modules and frontend, backend, gui, ... upgrade. The installer downloads these modules...
by JuergenB
Wed Jun 24, 2020 3:04 pm
Forum: Installation & Upgrades
Topic: error in 20.04 sql upgrade script - userrights.sql
Replies: 6
Views: 314

Re: error in 20.04 sql upgrade script - userrights.sql

Thanks,

this is a clean fresh installed OpenEMM database from installer 19.10.

I verified the 19.10 sql script, there is no 'campaign.autoopt' in this script.

Do i need to insert this into openemm or emm database?
Can we get a fixed installer?

Thanks

Jürgen
by JuergenB
Tue Jun 23, 2020 9:10 pm
Forum: Installation & Upgrades
Topic: error in 20.04 sql upgrade script - userrights.sql
Replies: 6
Views: 314

error in 20.04 sql upgrade script - userrights.sql

Hi, i need some help in upgrading from 19.10 to 20.04 I have a clean installation with a fresh database. I dropped the old database and create a new one for testing. I have these modules installed. runtime 19.10.009.016 frontend 19.10.000.170 backend 19.10.000.128 and if i upgrade these modules i ge...
by JuergenB
Fri Jun 19, 2020 6:43 pm
Forum: Installation & Upgrades
Topic: Runtime Deploymnet fails?
Replies: 3
Views: 195

Re: Runtime Deploymnet fails?

I found a good way to install 20.04 with CentOS 8 now.

compile Python 3.8.3
dnf -y install mariadb-server
dnf -y install mariadb-devel
python3 -m pip install mysqlclient
by JuergenB
Fri Jun 19, 2020 4:31 pm
Forum: Installation & Upgrades
Topic: 20.04 faulty DB creation script ?!?
Replies: 3
Views: 200

Re: 20.04 faulty DB creation script ?!?

Additional error in DBMS config during the configuration of DBMS you are asked to enter the root Password for the db creation. This Fails. Do you want to create a new database and database user with this credentials? (y/N, Blank => Cancel) > y Please enter database root use r password: This doesn´t...
by JuergenB
Wed Jun 17, 2020 5:08 pm
Forum: Suggestions
Topic: Python 3.8 compilation and /home/openemm
Replies: 0
Views: 326

Python 3.8 compilation and /home/openemm

Hi, the guide says to compile Python 3.8 first and later the openemm user will be created. If you compile first, you should create /home/openemm/opt/Python-3.8.2 as user openemm . In Chapter 12 you do this as root with mkdir /home/openemm/opt/Python-3.8.2 Later if you extrat the runtime in 5.2 as us...
by JuergenB
Wed Jun 17, 2020 4:52 pm
Forum: Installation & Upgrades
Topic: 20.04 faulty DB creation script ?!?
Replies: 3
Views: 200

Re: 20.04 faulty DB creation script ?!?

Hi, tried again and it fails (on the first try). I tried to document the error after step 5.1 OpenEMM Download 5.2 Runtime Deployment # Configure basic environment , install tomcat, exit installer su - root -c "/home/openemm/bin/OpenEMMInstaller.sh;exit" # Configure dbms ; restart OpenEMM system as ...
by JuergenB
Wed Jun 17, 2020 4:42 pm
Forum: Installation & Upgrades
Topic: 20.04 runtime installs wrong wkhtmltopdf @ CentOS 8
Replies: 0
Views: 218

20.04 runtime installs wrong wkhtmltopdf @ CentOS 8

Hi, the current runtimer 20.04.000.043 installs the wrong runtime module I use CentOS Linux release 8.2.2004 (Core) during base environment. And the runtime installs wkhtmltox-0.12.5-1.centos7.x86_64.rpm Please enter path for wkhtmltopdf (Blank => Cancel): > Install wkhtmltopdf and wkhtmltoimage by ...
by JuergenB
Tue Jun 16, 2020 10:27 pm
Forum: Installation & Upgrades
Topic: 20.04 faulty DB creation script ?!?
Replies: 3
Views: 200

20.04 faulty DB creation script ?!?

Hi, i tried several installations with 20.04 and 19.10 With 20.04 runtime i was never able to create the openemm database, i had a lot of errors. The runtime wasn´t able to create the initial openemm and emm database at all. So i had a crashed 20.04 with a faulty database. I extracted the 19.10 runt...
by JuergenB
Tue Jun 16, 2020 4:15 pm
Forum: Installation & Upgrades
Topic: Install issues
Replies: 50
Views: 1410

Re: Install issues

Please verify

7.2 Updating Tomcat

If you update Tomcat to a version higher than 9.0.30, you have to remove this line from file server.xml in directory home/openemm/conf:
<Connector port="8009" protocol="AJP/1.3" redirectPort="8443"
useBodyEncodingForURI="true" />
by JuergenB
Mon Jun 15, 2020 3:45 pm
Forum: Installation & Upgrades
Topic: 5.3 Frontend and Backend Deployment - fails MySQLdb exceptions
Replies: 0
Views: 253

5.3 Frontend and Backend Deployment - fails MySQLdb exceptions

I tired the installation with CentOS 8 and 20.04 runtime. i installed the base parts and python3-devel for the mariadb mysqlclient (python3 -m pip install mysqlclient). thas was ok, later i compiled the Python 3.8 I did the runtime deployment 5.2 as openemm user. I configured the environment and the...
by JuergenB
Mon Jun 15, 2020 2:01 pm
Forum: Suggestions
Topic: Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?
Replies: 4
Views: 195

Re: Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?

Thanks,

i use the installer openemm-runtime-20.04.000.043.tar with CentOS 8, minimal install.
and i don´t install python3 i compile python 3.8.

Can you fork the documentation to 19.10 with CentOS 7 and 20.04 with CentOS 8?
by JuergenB
Mon Jun 15, 2020 1:58 pm
Forum: Installation & Upgrades
Topic: Runtime Deploymnet fails?
Replies: 3
Views: 195

Re: Runtime Deploymnet fails?

Thats right. If you use CentOS 7 and OpenEMM 19.x: # yum install python If you use CentOS 8 and OpenEMM 19.x: # yum install python2 python2-lxml python2-dns python2-pip python2-devel # alternatives --set python /usr/bin/python2 If you use OpenEMM 20.04, you have to compile Python 3.8 or later But no...
by JuergenB
Mon Jun 15, 2020 1:50 pm
Forum: Suggestions
Topic: Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?
Replies: 4
Views: 195

Re: Admin Guide 1.3.2 - pyhton3 usage, before compilation? how?

This is the software stack required by OpenEMM 19.04 and later: • 64-bit version of RedHat 7/CentOS 7 or RedHat 8/CentOS 8 or SLES 15 • Java Open JDK 8 (any OpenEMM) or 11 (OpenEMM 20.04) • Apache Tomcat 9 • Python 2.7 (OpenEMM 19.x) or Python 3.8 (OpenEMM 20.04) • DBMS: MariaDB 10.1, 10.2 or 10.3; ...