Search found 10 matches

by aso
Thu Jun 25, 2020 8:35 am
Forum: Installation & Upgrades
Topic: error in 20.04 sql upgrade script - userrights.sql
Replies: 6
Views: 134

Re: error in 20.04 sql upgrade script - userrights.sql

Please try our new released Version 20.04.000.155.
It is available via the standard update process and should fix this problem.
by aso
Wed Jun 24, 2020 3:22 pm
Forum: Installation & Upgrades
Topic: error in 20.04 sql upgrade script - userrights.sql
Replies: 6
Views: 134

Re: error in 20.04 sql upgrade script - userrights.sql

Didn't you write you tried to install "frontend 20.04.000.143" in your first post?
Does the error happen in version 20.04 or 19.10?
In 19.10 this permission did not exist.
It is new in 20.04.
by aso
Wed Jun 24, 2020 12:00 pm
Forum: Installation & Upgrades
Topic: error in 20.04 sql upgrade script - userrights.sql
Replies: 6
Views: 134

Re: error in 20.04 sql upgrade script - userrights.sql

Line 18 means the permission "campaign.autoopt". Maybe this permission entry vanished somehow in your database. Please try this statement and re-execute the userrights.sql. INSERT INTO permission_tbl (permission_name, category, sub_category, sort_order, feature_package) VALUES ('campaign.autoopt', '...
by aso
Fri May 15, 2020 11:59 am
Forum: Bugs, bug fixes & releases
Topic: No layoutdata for favicon.ico
Replies: 3
Views: 192

Re: No layoutdata for favicon.ico

Hello, It seems like something went wrong in the initial migration to the new version. Please execute the following SQL Statement once on your database. Then restart the OpenEMM. This will execute the migration for the layout logos again. This should fix the Logo problem once for all. After the Rest...
by aso
Mon Feb 10, 2020 2:07 pm
Forum: Installation & Upgrades
Topic: openEMM 2019: Webservice-API throws Error 500
Replies: 11
Views: 1279

Re: openEMM 2019: Webservice-API throws Error 500

Hello, I also checked the currently available online Version of the OpenEMM Runtime (19.10.009.016). - It copies server.xml.template to server.xml if there is no server.xml yet - It backups and restores an existing server.xml As far as I can see there is no problem with the current version. Does the...
by aso
Fri Dec 06, 2019 1:45 pm
Forum: Installation & Upgrades
Topic: installing openemm 2019 not working on centos
Replies: 41
Views: 4722

Re: installing openemm 2019 not working on centos

Problem ist that the property value "dbms" in your "dbcfg"-file is missing.
Default location of that file is "/opt/agnitas.com/etc/dbcfg".
Other locations may be:
- "/home/openemm/etc/dbcfg"
- "/opt/openemm/dbcfg"
It should contain one of the following values:
- "mysql"
- "mariadb"
by aso
Mon Oct 14, 2019 12:23 pm
Forum: Installation & Upgrades
Topic: Failed on installation
Replies: 17
Views: 2240

Re: Failed on installation

This version should do.
So there is another point: Does your password include an "'" (apostrophe) ?
because the syntax of the mysql client is as follows:
mysql -u <username> -p'<password>' <dbname>
Maybe you could change your password to something more simple, just for some testing?
by aso
Thu Oct 10, 2019 4:12 pm
Forum: Installation & Upgrades
Topic: Failed on installation
Replies: 17
Views: 2240

Re: Failed on installation

Hello, What version of the mysql client software do you use? Detect it with: # mysql -V The parameter -p is used for the password as parameter when calling mysql to execute the fullldb sql script to create the database structure. Older versions of mysql do not allow this parameter for security reaso...
by aso
Thu Jul 18, 2019 2:30 pm
Forum: Installation & Upgrades
Topic: Error while detecting Wkhtml version
Replies: 2
Views: 761

Re: Error while detecting Wkhtml version

The wkhtml detection is done via
${wkhtmltopdf} -V

In your case:
/usr/local/bin/wkhtmltopdf -V

If that gives an os error the shown message comes up.
by aso
Fri Jun 19, 2015 12:50 pm
Forum: Usability
Topic: Auto Import
Replies: 4
Views: 8515

Re: Auto Import

The normal Import allows you to use a local file to upload and import. Auto-Import tries to use files from a SFTP- or FTP-server, because no user is connected with his local system to the OpenEMM when the auto-import is executed. Do you have a SFTP- or FTP-server running on your local system? If so,...