Search found 15 matches

by johanntagle
Thu Sep 25, 2014 3:30 am
Forum: Bugs, bug fixes & releases
Topic: 2013R2 date-based target group date arithmetic in quotes
Replies: 4
Views: 8257

Re: 2013R2 date-based target group date arithmetic in quotes

Ok thanks maschoff, that worked. Would like to take this opportunity though to reiterate my post at https://forum.openemm.org/development-f7/topic2765.html#p9023 - I mentioned there the "wish" to have an option to not use date_format() for a date-based target group definition and allow the user to d...
by johanntagle
Wed Sep 24, 2014 7:35 am
Forum: Bugs, bug fixes & releases
Topic: 2013R2 date-based target group date arithmetic in quotes
Replies: 4
Views: 8257

Re: 2013R2 date-based target group date arithmetic in quotes

Btw system info:

Operating System: Ubuntu 12.04.5 LTS

$ java -version
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_67-b01)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

Tomcat 6.041
by johanntagle
Wed Sep 24, 2014 6:57 am
Forum: Development
Topic: Optimizing SQL
Replies: 5
Views: 9334

Re: Optimizing SQL

Me again =) It would be nice if you can allow a date-based target group definition that doesn't make use of date_format. I understand the usefulness of matching a MMDD-formated date for birthdays and anniversaries but for use-cases such as "3 days ago" or newer than a certain date, it's more efficie...
by johanntagle
Wed Sep 24, 2014 5:21 am
Forum: Bugs, bug fixes & releases
Topic: 2013R2 date-based target group date arithmetic in quotes
Replies: 4
Views: 8257

2013R2 date-based target group date arithmetic in quotes

First time for me to create new date-based target group ever since upgrading from 2013 to 2013R2. It looks like it now encloses any filter clause in quotes, causing it to be treated as a string. I installed a new openemm instance to make sure it's not just happening to my live machine. I created a s...
by johanntagle
Tue Aug 19, 2014 4:50 am
Forum: Development
Topic: Optimizing SQL
Replies: 5
Views: 9334

Re: Optimizing SQL

So I found two notable entries in my slow query log. The first: sql_text: DELETE cust, bind FROM customer_1_tbl cust, customer_1_binding_tbl bind WHERE cust.customer_id=bind.customer_id AND bind.user_status=5 AND bind.change_date < date_sub(curdate(), interval 30 day) query_time: 00:01:19 mysql> exp...
by johanntagle
Tue Aug 19, 2014 3:33 am
Forum: Development
Topic: Optimizing SQL
Replies: 5
Views: 9334

Re: Optimizing SQL

Okay maschoff I will. If there's any specific area you are aware the query is slow do let me know and I will look at that first. I intend to use OpenEMM in the long term so I'm very game to contribute.
by johanntagle
Mon Aug 18, 2014 9:40 am
Forum: Development
Topic: Optimizing SQL
Replies: 5
Views: 9334

Optimizing SQL

Hi. So far I like what I see in OpenEMM, and it's much better than a certain commercial product we bought last year. However, every now and then I see SQL's that badly need revising. Since OpenEMM only support MySQL, why not optimize for MySQL? Here's one - when you do a search for a recipient using...
by johanntagle
Mon Aug 11, 2014 7:37 am
Forum: Using OpenEMM
Topic: valid sourcegroup_id values
Replies: 2
Views: 2650

Re: valid sourcegroup_id values

Thanks Maschoff!
by johanntagle
Wed Aug 06, 2014 7:34 am
Forum: Using OpenEMM
Topic: valid sourcegroup_id values
Replies: 2
Views: 2650

valid sourcegroup_id values

Hi. What are valid values for sourcegroup_id? I was hoping to manually keep track of recipients I uploaded directly to the database using datasource_description_tbl but I don't know what I should put for sourcegroup_id. I just need one value I can use for manual imports and it would also be nice to ...
by johanntagle
Wed Aug 06, 2014 3:35 am
Forum: Bugs, bug fixes & releases
Topic: org.hibernate.PropertyValueException when creating mailing
Replies: 1
Views: 6307

Re: org.hibernate.PropertyValueException when creating maili

For now I made all columns of mailing_tbl except mailing_id and change_date nullable, hopefully it doesn't break anywhere else. Also noted that row inserted after I assign a target group to the mailing has values for all previously non-nullable columns.
by johanntagle
Tue Aug 05, 2014 10:40 pm
Forum: Bugs, bug fixes & releases
Topic: org.hibernate.PropertyValueException when creating mailing
Replies: 1
Views: 6307

org.hibernate.PropertyValueException when creating mailing

Hi. I got OpenEMM 2013 working for more than a month now and was happy with it. Recently we transferred databases from an Amazon EC2 instance to their RDS service. OpenEMM seemed to be working after the transfer, though admittedly we only tested logging on. Now whenever we create a new mailing I get...
by johanntagle
Tue Jul 22, 2014 4:09 am
Forum: Using OpenEMM
Topic: OpenEMM 2013 WS GetSubscriber searching for customer 0?
Replies: 1
Views: 2929

Re: OpenEMM 2013 WS GetSubscriber searching for customer 0?

Okay I think I got it... my soap client didn't put the proper namespace.
by johanntagle
Tue Jul 22, 2014 3:40 am
Forum: Using OpenEMM
Topic: OpenEMM 2013 WS GetSubscriber searching for customer 0?
Replies: 1
Views: 2929

OpenEMM 2013 WS GetSubscriber searching for customer 0?

Before anything, thank you for making this product open source. So far it has performed way better than a certain commercial product my company was using. I'm in the process of installing 2013 R2 on a new machine but would like to ask about this problem I'm encountering using Webservice 2.0 (on 2013...
by johanntagle
Tue Jul 22, 2014 12:09 am
Forum: Installation & Upgrades
Topic: Can not get the webservice app running
Replies: 6
Views: 9565

Re: Can not get the webservice app running

Ok thanks for that. I encountered an error trying 2013R2 before but will try it again and post a new message if I encounter problems again.
by johanntagle
Mon Jul 21, 2014 6:11 am
Forum: Installation & Upgrades
Topic: Can not get the webservice app running
Replies: 6
Views: 9565

Re: Can not get the webservice app running

Just want to confirm that using JDK 6 also solved my problem. Hopefully it doesn't adversely affect the whole system. My question though, is this a permanent fix? Because the this thread is more than 1.5 years old and the install guide still specifically says use JDK 7.