Search found 23 matches

by nickw
Fri Nov 26, 2021 10:13 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

Also, using the guide to set up sendmail instead of postfix, does not work. I'm not going to build this out again just to list the errors your team should be fully aware of if you attempt to build your own product using the guide you publish.
by nickw
Fri Nov 26, 2021 9:57 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

And here is the console user being mentioned in the /home/openemm/tomcat/bin/emm.sh file: test_user() { if [ "${USER}" != "rdir" ] && [ "${USER}" != "console" ] && [ "${USER}" != "${ADDITIONAL_USER}" ]; then { echo "Wro...
by nickw
Fri Nov 26, 2021 9:44 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

here are all the lines that mention the "console" user in /home/openemm/tomcat/bin/OMT.py 892 # EMM information 893 if os.path.isdir("/home/console/release/emm") and (Environment.username == "console" or Utilities.hasRootPermissions()): 894 Environment.isEmmFrontendServ...
by nickw
Fri Nov 26, 2021 9:38 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

Java-1.8.0 is still being installed in this version: Root mode: On Hostname: hostname.com OpenEMM Runtime Version: 21.10.033 OpenEMM Version: Unknown System-Url: Unknown Invalid database vendor in dbcfg: Database Connection cannot be established. (Maybe database user or database connection parameter...
by nickw
Fri Nov 26, 2021 8:54 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

Version given by Agnitas: openemm-runtime-21.10.33, then upgraded to the following: ============================================= = OpenEMM Maintenance Tool (OMT) v21.10.043 = ============================================= Root mode: On Hostname: hostname.com OpenEMM License: OpenEMM (ID: 0) OpenEMM ...
by nickw
Fri Nov 26, 2021 8:08 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

To reproduce your steps it would be helpful to add the OMT version you are using. For instance, I am offered to install Tomcat-Native, so there seems to be a version with a bug. Also, I never see user console in my installation, because this user is reserved for the commercial version. This works w...
by nickw
Tue Nov 23, 2021 9:56 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

I have not configured TLS, or added any certs to this as of yet. I'm pretty sure they'll also not be easy to set up. I will update this guide when those pieces are figured out.


If anyone has any concerns or issues, I will respond and try to help as best as possible.
by nickw
Tue Nov 23, 2021 9:54 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

Notes: You do not need to disable selinux, just set it to permissive. This is not only a better security practice, but saves you from a reboot as well. You can install python at the same time you install mariadb, bypassing half of the guide. You also, do not need to do any extra configurations to ma...
by nickw
Tue Nov 23, 2021 9:52 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

Re: How to install OpenEMM on RHEL and its forks

### Continued from previous post cd /home/openemm/ bin/OMT.sh Please choose entry to change (Blank => Back): > JAVA_HOME Please enter path for JAVA_HOME (Blank => Cancel, 'Default' for '/usr/lib/jvm/java-11-openjdk-11.0.13.0.8-3.el8_5.x86_64'): > Default # Please choose entry to change (Blank => Bac...
by nickw
Tue Nov 23, 2021 9:50 pm
Forum: Installation & Upgrades
Topic: How to install OpenEMM on RHEL and its forks
Replies: 12
Views: 84

How to install OpenEMM on RHEL and its forks

Hello, After attempting to install OpenEMM on several different operating systems, following several guides listed at https://wiki.openemm.org/doku.php , for about 2 weeks. I have finally managed to get it running. Below is a guide I have tested by rebuilding a working OpenEMM at least 5 times to ma...
by nickw
Tue Nov 23, 2021 8:57 pm
Forum: Installation & Upgrades
Topic: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04
Replies: 13
Views: 371

Re: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04

If you install mariadb correctly, and java 11 correctly, get the database installed, get tomcat installed, this issue still persists: genrsa: Can't open "/home/console/tomcat/conf/keys/birt_private.pem" for writing, No such file or directory Can't open /home/console/tomcat/conf/keys/birt_p...
by nickw
Tue Nov 23, 2021 7:59 pm
Forum: Installation & Upgrades
Topic: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04
Replies: 13
Views: 371

Re: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04

When OMT.sh offers you to install java-1.8.*, exit the script and run: yum install java-11-openjdk Alright, mariadb doesn't want to work anymore. These were all issues following the latest guide, I will keep attacking this in the hopes it will work. In the mean time, can you please update the guide ...
by nickw
Tue Nov 23, 2021 7:47 pm
Forum: Installation & Upgrades
Topic: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04
Replies: 13
Views: 371

Re: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04

In section " 3.2 RHEL Operating System", it mentions OMT.sh will install JAVA 11. It will not. It will provide you with " java-1.8.0-openjdk java-1.8.0-openjdk-devel". The same version the guide tells you to remove, and the wrong version the guide tells you OMT.sh will install. f...
by nickw
Tue Nov 23, 2021 7:41 pm
Forum: Installation & Upgrades
Topic: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04
Replies: 13
Views: 371

Re: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04

Fixed the mariadb issue with the following: sed -i -e 's/LimitNOFILE=16384/LimitNOFILE=100000/' /usr/lib/systemd/system/mariadb.service echo "LimitMEMLOCK=100000" >> /usr/lib/systemd/system/mariadb.service; mkdir /var/run/mariadb; touch /var/run/mariadb/mariadb.pid; chmod ug+w /var/run/mar...
by nickw
Tue Nov 23, 2021 7:40 pm
Forum: Installation & Upgrades
Topic: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04
Replies: 13
Views: 371

Re: Python 3.8.8 and mariadb 10.3.28 not supported by 21.04

Submitted extra post in error, please see one below